Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019611
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2012-02-01 10:532012-04-26 19:32
ReporterxabiermerinoView Statuspublic 
Assigned Toeduardo_Argal 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision19148b0e53e6
ProjectionnoneETAnoneTarget Version3.0MP10
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP7.1SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019611: Wrong Journal Entry with different conversion rate in a payment

DescriptionYou have an invoice in CZK (120) with the conversion rate 25 in EUR is 3000. When you post the payment created in the financial account with a conversion rate 24.5 (in EUR 2940) this journal entry is created:

Diferencias positivas de cambio: CREDIT: 60 --> ok
Cuenta de compensación de asientos_ CREDIT: 0.03
Proveedores (euros) --> DEBIT: 3000.3
Bancos e instituciones de crédito.. : CREDIT: 2940
Steps To Reproduce- Change the currency from EUR to CZK in:
   * Price List: Precios Bebidas Alegres
   * Financia Account: Banco de España - Cuenta 1
- Introduce these conversion rates (see conversionrates.png)
- Create and post an invoice:
    - Price List: Precios Bebidas Alegres
    - BP: Bebidas alegres
    - Line Net amount: 120
    - Tax: Compras exentas
- Go to the Financial account, add the transaction of the payment and post it.
- Realize that the journal entry is wrong
   
TagsNo tags attached.
Attached Filespng file icon conversionrates.png [^] (22,614 bytes) 2012-02-01 10:59

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0046652)
jecharri (developer)
2012-03-22 12:36

It is not a bug
(0047516)
hgbot (developer)
2012-04-12 12:23

Repository: erp/devel/pi
Changeset: 19148b0e53e69a43cab75d16fe254a0d5da0eb15
Author: Eduardo Argal Guibert <eduardo.argal <at> openbravo.com>
Date: Thu Apr 12 12:15:28 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/19148b0e53e69a43cab75d16fe254a0d5da0eb15 [^]

Fixes bug 19611: Wrong Journal Entry with different conversion rate in a payment

---
M src/org/openbravo/erpCommon/ad_forms/AcctServer.java
M src/org/openbravo/erpCommon/ad_forms/FactLine.java
---
(0047637)
hudsonbot (developer)
2012-04-17 05:31

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/cedf57621434 [^]

Maturity status: Test
(0047946)
hgbot (developer)
2012-04-25 09:58

Repository: erp/devel/pi
Changeset: 7625a9ee9d4ce1c40777adc309f6c0ce7938bc62
Author: Mikel Irurita <mikel.irurita <at> openbravo.com>
Date: Wed Apr 25 09:57:41 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7625a9ee9d4ce1c40777adc309f6c0ce7938bc62 [^]

Related to issue 19611: update license text year

---
M src/org/openbravo/erpCommon/ad_forms/FactLine.java
---
(0047947)
mirurita (developer)
2012-04-25 10:08

testing OK

Accounting Schema F&B España, S.A. US/A/Euro
Account No. NAME DEBIT CREDIT
76800 Diferencias positivas de cambio 60,00
40000 Proveedores (euros) a corto plazo 3.000,00
57200 Bancos 2.940,00
(0048093)
hudsonbot (developer)
2012-04-26 19:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/70a717a9ffa1 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-02-01 10:53 xabiermerino New Issue
2012-02-01 10:53 xabiermerino Assigned To => jonalegriaesarte
2012-02-01 10:53 xabiermerino Modules => Core
2012-02-01 10:54 xabiermerino Issue Monitored: networkb
2012-02-01 10:59 xabiermerino File Added: conversionrates.png
2012-03-06 12:48 jonalegriaesarte Assigned To jonalegriaesarte => jecharri
2012-03-22 12:36 jecharri Note Added: 0046652
2012-03-22 12:36 jecharri Status new => closed
2012-03-22 12:36 jecharri Resolution open => no change required
2012-04-12 10:49 eduardo_Argal Assigned To jecharri => eduardo_Argal
2012-04-12 10:49 eduardo_Argal Status closed => new
2012-04-12 10:49 eduardo_Argal Resolution no change required => open
2012-04-12 10:51 eduardo_Argal Status new => scheduled
2012-04-12 10:51 eduardo_Argal fix_in_branch => pi
2012-04-12 12:23 hgbot Checkin
2012-04-12 12:23 hgbot Note Added: 0047516
2012-04-12 12:23 hgbot Status scheduled => resolved
2012-04-12 12:23 hgbot Resolution open => fixed
2012-04-12 12:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/19148b0e53e69a43cab75d16fe254a0d5da0eb15 [^]
2012-04-17 05:31 hudsonbot Checkin
2012-04-17 05:31 hudsonbot Note Added: 0047637
2012-04-25 09:58 hgbot Checkin
2012-04-25 09:58 hgbot Note Added: 0047946
2012-04-25 10:08 mirurita Note Added: 0047947
2012-04-25 10:08 mirurita Status resolved => closed
2012-04-26 19:32 hudsonbot Checkin
2012-04-26 19:32 hudsonbot Note Added: 0048093


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker