Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019556
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2012-01-24 18:262012-01-28 04:10
ReportermaiteView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision85a366534d3c
ProjectionnoneETAnoneTarget Version3.0MP8
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019556: Role defined as "Client + Organization" can not create data for Organization *

DescriptionIn Openbravo 2.50, when Role is defined with User Level= Client + Organization, it can create Business Partner for Organization *

In Openbravo 3, it can not create Business Partner for Organization *
Steps To Reproduce1. Go to Role window and create new role with user_level=Client + Organization
2. Go to Org Access tab and add record for "F&B España, S.A." organization
3. Go to User window and search for "Openbravo" user and, in tab User Roles, add access to your new role.
4. Logout and login again with Openbravo user and set your role
5. Go to Business Partner window, create new business partner for Organization * and try to save. You will obtain "Saving failed. With your current role this action is not allowed." error

If you follow same steps in 2.50 version you are able to save record
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0044543)
alostale (developer)
2012-01-25 10:11

The changeset adds organization * to the list of writable organizations in case the role's user level is Client + Organization (previously this was done in case it was System or Client).

It affects a very central part of DAL, but the regression risk it adds is very low because it is less restrictive than it was before so everything working before the fix should still work after it.
(0044544)
hgbot (developer)
2012-01-25 10:14

Repository: erp/devel/pi
Changeset: 85a366534d3ca56c742bb033d0b428d3a512d477
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Jan 25 10:13:04 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/85a366534d3ca56c742bb033d0b428d3a512d477 [^]

fixed bug 19556: "Client + Organization" roles cannot create data for Organization *

---
M src/org/openbravo/dal/core/OBContext.java
---
(0044564)
maite (developer)
2012-01-25 13:57

verified
(0044577)
psarobe (manager)
2012-01-25 18:03

Fix correct. Works fine
(0044649)
hudsonbot (developer)
2012-01-28 04:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8e16ef45b30c [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-01-24 18:26 maite New Issue
2012-01-24 18:26 maite Assigned To => jonalegriaesarte
2012-01-24 18:26 maite Modules => Core
2012-01-24 18:27 maite Assigned To jonalegriaesarte => alostale
2012-01-24 18:28 maite Target Version => 3.0MP8
2012-01-24 19:00 jpcalvente Issue Monitored: jpcalvente
2012-01-25 10:11 alostale Note Added: 0044543
2012-01-25 10:14 hgbot Checkin
2012-01-25 10:14 hgbot Note Added: 0044544
2012-01-25 10:14 hgbot Status new => resolved
2012-01-25 10:14 hgbot Resolution open => fixed
2012-01-25 10:14 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/85a366534d3ca56c742bb033d0b428d3a512d477 [^]
2012-01-25 13:57 maite Note Added: 0044564
2012-01-25 13:57 maite Status resolved => closed
2012-01-25 18:03 psarobe Note Added: 0044577
2012-01-28 04:10 hudsonbot Checkin
2012-01-28 04:10 hudsonbot Note Added: 0044649


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker