Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019463
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2012-01-11 16:222012-02-01 08:58
ReporterjecharriView Statuspublic 
Assigned Tojecharri 
PriorityhighResolutionfixedFixed in Version3.0MP8
StatusclosedFix in branchFixed in SCM revision1c7cc06530d5
ProjectionnoneETAnoneTarget Version3.0MP8
OSLinux 32 bitDatabasePostgreSQLJava version
OS VersionCommunity ApplianceDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019463: Read Only Logic for columns is applied incorrectly

DescriptionCurrently, there are several ways to make some tabs/fields read only:
- A role may have access but not write permission to a window.
- A window can be of type "query"
- A tab can have a UI Pattern of Read Only
- A single field within a Tab can be Read Only
- A column can be non updatable (meaning that it can only be edited when creating a record)
- A column can have a Read Only Logic that will make the field read only dynamically, similar to Display Logics, but at a column level.


Read Only Logic should only be validated / applied if the previous conditions are not met, e.g. the column should be already editable.

Currently, Read Only Logic can make editable some fields which are not designed to be.
Steps To Reproduce1. Give an editable column a read only logic of 'false'. This means it should always be editable.
2. Make read only a field for this column
3. The field is editable even if it has been set to read only in this tab, since it is following the Read Only Logic rule instead of its field AD information.
Proposed SolutionRevise the whole read only functionality
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0017395 closedjecharri Read Only Logic for columns is applied incorrectly 

-  Notes
(0044397)
hgbot (developer)
2012-01-16 13:20

Repository: erp/devel/pi
Changeset: 1c7cc06530d5faf57bf0aaafa43332d6c8293063
Author: Javier Etxarri <javier.echarri <at> openbravo.com>
Date: Mon Jan 16 13:10:38 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1c7cc06530d5faf57bf0aaafa43332d6c8293063 [^]

Fixes issue 17395, Fixes issue 19463: Read Only Logic for columns is applied incorrectly.
Now the readonlylogic expression is not going to be applied until the application check if the field is defined as read only

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewFieldHandler.java
---
(0044432)
hudsonbot (developer)
2012-01-18 14:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0035a0985219 [^]

Maturity status: Test
(0044716)
hgbot (developer)
2012-01-30 18:14

Repository: erp/devel/pi
Changeset: a052b9bb86e5a76902755ba6c08da5fc02550923
Author: Javier Etxarri <javier.echarri <at> openbravo.com>
Date: Mon Jan 30 18:13:28 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a052b9bb86e5a76902755ba6c08da5fc02550923 [^]

issue 17395, issue 19463: Read Only Logic for columns is applied incorrectly.
Now the read only logic is applied correctly for fields without column related (OBClientClassField)

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewFieldHandler.java
---
(0044721)
AugustoMauch (developer)
2012-01-31 09:16

Code reviewed and fix verified
(0044752)
hudsonbot (developer)
2012-02-01 08:58

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/933a9b7b9d89 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2012-01-11 16:22 jecharri New Issue
2012-01-11 16:22 jecharri Assigned To => jecharri
2012-01-11 16:22 jecharri Web browser => Google Chrome
2012-01-11 16:22 jecharri Modules => Core
2012-01-11 16:22 jecharri Issue generated from 0017395
2012-01-11 16:22 jecharri Relationship added related to 0017395
2012-01-11 16:33 maria_perez Issue Monitored: maria_perez
2012-01-16 13:20 hgbot Checkin
2012-01-16 13:20 hgbot Note Added: 0044397
2012-01-16 13:20 hgbot Status new => resolved
2012-01-16 13:20 hgbot Resolution open => fixed
2012-01-16 13:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1c7cc06530d5faf57bf0aaafa43332d6c8293063 [^]
2012-01-18 14:22 hudsonbot Checkin
2012-01-18 14:22 hudsonbot Note Added: 0044432
2012-01-30 18:14 hgbot Checkin
2012-01-30 18:14 hgbot Note Added: 0044716
2012-01-31 09:16 AugustoMauch Note Added: 0044721
2012-01-31 09:16 AugustoMauch Status resolved => closed
2012-01-31 09:16 AugustoMauch Fixed in Version => 3.0MP8
2012-02-01 08:58 hudsonbot Checkin
2012-02-01 08:58 hudsonbot Note Added: 0044752


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker