Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019288
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2011-12-13 12:302011-12-22 09:10
ReportermtaalView Statuspublic 
Assigned Tomarvintm 
PrioritynormalResolutionfixedFixed in Version3.0MP7
StatusclosedFix in branchFixed in SCM revision348eada6eeb6
ProjectionnoneETAnoneTarget Version3.0MP7
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP6SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019288: Changing the organization does not recompute combos

DescriptionThere are cases where the organization (and client?) column does not have a validation/callout. This means that the org id is not considered to be a dynamic column and changing the organization in the client will not update/recompute the other combos.

The FIC should ensure that the org (and client?) are always part of dynamiccols
Steps To Reproduce- go to the product window
- create new (in form)
- change the organization
- notice that other combos are not recomputed
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0043818)
marvintm (developer)
2011-12-13 12:47

The change will consist in forcing the Form Initialization Component to consider the Organization column as a "change event column" (which always produces a call to the FIC when the user changes its value), even in cases the organization column doesn't explicitly appear in any validation of any column of the window.

The regression chance is very low, as the only implication this change will have is that the change in the value of the Organization for any record will trigger a FIC call, which will reload the combos.
(0043819)
hgbot (developer)
2011-12-13 12:54

Repository: erp/devel/pi
Changeset: 348eada6eeb613cb504ca7074735c33ff55a455b
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Tue Dec 13 06:53:56 2011 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/348eada6eeb613cb504ca7074735c33ff55a455b [^]

Fixed issue 19288. The organization window will always be considered a change event column.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
---
(0043865)
hudsonbot (developer)
2011-12-14 10:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8dbb94fbbb00 [^]

Maturity status: Test
(0044000)
alostale (developer)
2011-12-22 09:10

Verified on pi@d17b74061474

*Code review: ok
*Test:
  -Login with group admin
  -Go to product window
  -Select US organization -> Check tax category values are US ones
  -Change organization to Spain one -> Check tax category values are Spain ones
*Regression risk: Even though this is an horizontal change affecting every window in the application, the risk it has is low because if affects just to ad_org_id column changes.

- Issue History
Date Modified Username Field Change
2011-12-13 12:30 mtaal New Issue
2011-12-13 12:30 mtaal Assigned To => marvintm
2011-12-13 12:30 mtaal Modules => Core
2011-12-13 12:47 marvintm Note Added: 0043818
2011-12-13 12:54 hgbot Checkin
2011-12-13 12:54 hgbot Note Added: 0043819
2011-12-13 12:54 hgbot Status new => resolved
2011-12-13 12:54 hgbot Resolution open => fixed
2011-12-13 12:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/348eada6eeb613cb504ca7074735c33ff55a455b [^]
2011-12-14 10:44 hudsonbot Checkin
2011-12-14 10:44 hudsonbot Note Added: 0043865
2011-12-22 09:10 alostale Note Added: 0044000
2011-12-22 09:10 alostale Status resolved => closed
2011-12-22 09:10 alostale Fixed in Version => 3.0MP7


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker