Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0019273
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2011-12-09 14:042015-02-24 11:24
ReporterpsarobeView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionout of dateFixed in Version
StatusclosedFix in branchFixed in SCM revisionf22a1c536caf
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0019273: Different criteria when saving records that contains entities that don't belong to the org tree

DescriptionDifferent criteria when saving records that contains entities that don't belong to the org tree
Steps To ReproducePrerequisities:
Need to follow steps of issue 19272

1. Go to Goods shipment window. Click New
2. Select organization F&B España, S.A
3. Select customer "Alimentos y Supermercados". Click Save
4. Move to lines and click new in form
5. Open the product selector and clean the filters
6. Select product "Sirof" and click OK
7. Click Attribute Set Value and select option "Blue" and click OK
8. Click Save

The system allows you save the record while in issue 19272 it doesn't.
NOTICE the m_attributesetintance_id has the org F&B US, inc. but the org of the document is F&B España
TagsNo tags attached.
Attached Filesdiff file icon 19273.diff [^] (6,012 bytes) 2011-12-14 11:06 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 00192723.0MP7 closedjonalegriaesarte M_attributesetinstance is taking the org from the organization you have logged in 
blocks design defect 0032063 acknowledgedplatform References from an object to other objects is not checked when inserting only when updating 

-  Notes
(0043853)
hgbot (developer)
2011-12-13 18:52

Repository: erp/devel/pi
Changeset: f22a1c536caf8774de2172ead180af6604a86148
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Tue Dec 13 18:52:27 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f22a1c536caf8774de2172ead180af6604a86148 [^]

Fixes issue 19273: Different criteria when saving records that contains entities that don't belong to the org tree

---
M src/org/openbravo/dal/core/OBInterceptor.java
---
(0043854)
mtaal (developer)
2011-12-13 18:58

This is related to the organization check on referenced entities:
http://wiki.openbravo.com/wiki/Data_Access_Layer#Entity_Organization_Validation [^]

The fix does 2 things:
- enabled organization checking for new records, this was not being done yet..
- prevent the check for organizations for attribute set instances, this because attribute set instances can belong to wrong organizations in existing data:
https://issues.openbravo.com/view.php?id=19272 [^]
(0043858)
hgbot (developer)
2011-12-13 19:35

Repository: erp/devel/pi
Changeset: 59b589e6073619357842e211c8d2d7c32a4c04e1
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Tue Dec 13 19:35:02 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/59b589e6073619357842e211c8d2d7c32a4c04e1 [^]

Related to issue 19273: Different criteria when saving records that contains entities that don't belong to the org tree
Changed import sample data to prevent org check

---
M build.xml
---
(0043867)
mtaal (developer)
2011-12-14 11:05

Will be re-applied in MP9
(0043868)
hgbot (developer)
2011-12-14 11:09

Repository: erp/devel/pi
Changeset: 4131eb5bea35b9c9bd88e6a7076f4fe55e40783f
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Wed Dec 14 11:09:22 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4131eb5bea35b9c9bd88e6a7076f4fe55e40783f [^]

Related to issue 19273: Different criteria when saving records that contains entities that don't belong to the org tree
Reverted/commented changes, re-apply in MP9

---
M build.xml
M src/org/openbravo/dal/core/OBInterceptor.java
---
(0043869)
mtaal (developer)
2011-12-14 11:10
edited on: 2011-12-14 11:30

For MP9:
- revert this changeset (see below):
http://code.openbravo.com/erp/devel/pi/rev/61149227461ba35beaf14e7ed75730ebea6f2946 [^]
- apply the attached diff

(0043870)
hgbot (developer)
2011-12-14 11:29

Repository: erp/devel/pi
Changeset: 61149227461ba35beaf14e7ed75730ebea6f2946
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Wed Dec 14 11:29:24 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/61149227461ba35beaf14e7ed75730ebea6f2946 [^]

Related to issue 19273: Different criteria when saving records that contains entities that don't belong to the org tree

---
M build.xml
M src/org/openbravo/dal/core/OBInterceptor.java
---
(0043914)
hudsonbot (developer)
2011-12-17 03:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/919bff4169c5 [^]

Maturity status: Test
(0043918)
hudsonbot (developer)
2011-12-17 03:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/919bff4169c5 [^]

Maturity status: Test
(0043919)
hudsonbot (developer)
2011-12-17 03:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/919bff4169c5 [^]

Maturity status: Test
(0043920)
hudsonbot (developer)
2011-12-17 03:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/919bff4169c5 [^]

Maturity status: Test
(0044896)
mtaal (developer)
2012-02-06 16:09

Hi Pablo,
I am retesting this issue, but now the attribute set instance gets saved with org 0. Is this indeed correct? It does not seem so..

gr. Martin
(0074835)
alostale (developer)
2015-02-24 11:24

out of date: in feedback for more than 3 years

- Issue History
Date Modified Username Field Change
2011-12-09 14:04 psarobe New Issue
2011-12-09 14:04 psarobe Assigned To => mtaal
2011-12-09 14:04 psarobe Modules => Core
2011-12-09 14:04 psarobe Relationship added depends on 0019272
2011-12-09 14:09 psarobe Steps to Reproduce Updated View Revisions
2011-12-13 18:52 hgbot Checkin
2011-12-13 18:52 hgbot Note Added: 0043853
2011-12-13 18:52 hgbot Status new => resolved
2011-12-13 18:52 hgbot Resolution open => fixed
2011-12-13 18:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f22a1c536caf8774de2172ead180af6604a86148 [^]
2011-12-13 18:58 mtaal Note Added: 0043854
2011-12-13 19:35 hgbot Checkin
2011-12-13 19:35 hgbot Note Added: 0043858
2011-12-14 11:05 mtaal Note Added: 0043867
2011-12-14 11:05 mtaal Status resolved => new
2011-12-14 11:05 mtaal Resolution fixed => open
2011-12-14 11:06 mtaal File Added: 19273.diff
2011-12-14 11:09 hgbot Checkin
2011-12-14 11:09 hgbot Note Added: 0043868
2011-12-14 11:10 mtaal Note Added: 0043869
2011-12-14 11:10 mtaal Target Version 3.0MP7 => 3.0MP9
2011-12-14 11:29 hgbot Checkin
2011-12-14 11:29 hgbot Note Added: 0043870
2011-12-14 11:30 mtaal Note Edited: 0043869 View Revisions
2011-12-17 03:07 hudsonbot Checkin
2011-12-17 03:07 hudsonbot Note Added: 0043914
2011-12-17 03:07 hudsonbot Checkin
2011-12-17 03:07 hudsonbot Note Added: 0043918
2011-12-17 03:07 hudsonbot Checkin
2011-12-17 03:07 hudsonbot Note Added: 0043919
2011-12-17 03:07 hudsonbot Checkin
2011-12-17 03:07 hudsonbot Note Added: 0043920
2012-02-06 16:09 mtaal Note Added: 0044896
2012-02-06 16:09 mtaal Status new => feedback
2012-03-01 10:26 alostale Target Version 3.0MP9 =>
2012-09-28 11:34 AugustoMauch Assigned To mtaal => shankarb
2012-09-28 11:47 shankarb Assigned To shankarb => mtaal
2012-10-03 09:35 AugustoMauch Assigned To mtaal => AugustoMauch
2015-02-24 11:24 alostale Note Added: 0074835
2015-02-24 11:24 alostale Status feedback => closed
2015-02-24 11:24 alostale Resolution open => out of date
2016-01-29 16:47 mtaal Relationship added blocks 0032063


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker