Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0018909
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2011-10-27 16:522011-11-28 09:46
ReporterpjuvaraView Statuspublic 
Assigned Todbaz 
PrioritynormalResolutionfixedFixed in Version3.0MP6
StatusclosedFix in branchpiFixed in SCM revision7b8f68718e5b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP4SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0018909: Account combination selector opens up with %undefined

DescriptionWhen you open a selector for an account combination field that is already populated (example: you want to change the account value), the selector opens up with a prefilter of "undefined%", which needs to be removed in order to select a new value.
Steps To ReproduceSee attachment.
TagsNo tags attached.
Attached Files? file icon out.ogv [^] (1,691,814 bytes) 2011-10-27 16:52

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0042982)
dbaz (developer)
2011-11-18 12:44

This should be included in project "All complex references (location, account, attribute set) implemented in the new technology" which is in our product backlog.
(0043091)
dbaz (developer)
2011-11-22 18:22

The right behavior for classic selectors is that the selector popup gets opened filtered by the 'text' wrote in the input.

In case of 2.50 it made sense, since you can wrote in the input and open the popup at anypoint to select a record.

In case of 3.00 since you can't write in the input anymore, it makes no sense.

The issue is going to be fixed following the 2.50 pattern (in the way the classic selector was designed). It doesn't make sense rebuild the concept of classic selector when we have the new technology in place.
(0043098)
hgbot (developer)
2011-11-22 19:10

Repository: erp/devel/pi
Changeset: 7b8f68718e5b5885bad2d259ce1918cabd8c5f20
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Tue Nov 22 19:09:23 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/7b8f68718e5b5885bad2d259ce1918cabd8c5f20 [^]

Fixed issue 18909: 'undefined' text is not shown anymore in classic selector popups

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-search.js
---
(0043110)
hudsonbot (developer)
2011-11-23 15:52

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/19e910a4cbc4 [^]

Maturity status: Test
(0043380)
mtaal (developer)
2011-11-27 21:32

Reviewed
(0043383)
dbaz (developer)
2011-11-28 08:45

Changed to "defect" again
(0043386)
mtaal (developer)
2011-11-28 09:45

.
(0043387)
mtaal (developer)
2011-11-28 09:46

.
(0043388)
mtaal (developer)
2011-11-28 09:46

Reviewed

- Issue History
Date Modified Username Field Change
2011-10-27 16:52 pjuvara New Issue
2011-10-27 16:52 pjuvara Assigned To => dbaz
2011-10-27 16:52 pjuvara File Added: out.ogv
2011-10-27 16:52 pjuvara Modules => Core
2011-11-18 12:44 dbaz Note Added: 0042982
2011-11-22 15:58 dbaz Type defect => design defect
2011-11-22 18:22 dbaz Note Added: 0043091
2011-11-22 19:10 hgbot Checkin
2011-11-22 19:10 hgbot Note Added: 0043098
2011-11-22 19:10 hgbot Status new => resolved
2011-11-22 19:10 hgbot Resolution open => fixed
2011-11-22 19:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7b8f68718e5b5885bad2d259ce1918cabd8c5f20 [^]
2011-11-23 15:52 hudsonbot Checkin
2011-11-23 15:52 hudsonbot Note Added: 0043110
2011-11-27 21:32 mtaal Note Added: 0043380
2011-11-27 21:32 mtaal Status resolved => closed
2011-11-27 21:32 mtaal Fixed in Version => 3.0MP6
2011-11-28 08:45 dbaz Note Added: 0043383
2011-11-28 08:45 dbaz Status closed => new
2011-11-28 08:45 dbaz Resolution fixed => open
2011-11-28 08:45 dbaz Fixed in Version 3.0MP6 =>
2011-11-28 08:45 dbaz Type design defect => defect
2011-11-28 09:45 mtaal Status new => scheduled
2011-11-28 09:45 mtaal Note Added: 0043386
2011-11-28 09:45 mtaal fix_in_branch => pi
2011-11-28 09:46 mtaal Note Added: 0043387
2011-11-28 09:46 mtaal Status scheduled => resolved
2011-11-28 09:46 mtaal Fixed in Version => 3.0MP6
2011-11-28 09:46 mtaal Resolution open => fixed
2011-11-28 09:46 mtaal Note Added: 0043388
2011-11-28 09:46 mtaal Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker