Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0018806
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementminoralways2011-10-19 10:412012-01-12 10:26
ReportermiruritaView Statuspublic 
Assigned ToioritzCia 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiondd8e5b8f8fa6
ProjectionnoneETAnoneTarget Version3.0MP8
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0018806: Order unit (secondary unit) - Physical Inventory Lines: order quantity changes

DescriptionIf you are working with secondary unit (order unit) you must activate some tabs and fields because by default they are hidden.

Order quantity in Physical Inventory Lines should be visible (because it already has a displaylogic for secondary unit).
Furthermore, it must go before the Quantity count field because the Order Quantity field has a callout which changes the value of the Quantity count.

Now, the user will fill the Quantity count (because goes first) but the Order quantity will not be changed according to the conversion defined for the secondary unit of the product.

As a result the inventory line entered is wrong and the further stock movements of this concrete products will be wrong.
Steps To Reproduce1) Prepare application to work with secondary unit. (make visible Physical Inventory Lines - order quantity field)
2) Create a new product
3) Go to UOM tab and create a new UOM
4) Navigate to this UOM and create a conversion from the secondary UOM to the UOM defined for the product.
5) Create a new physical inventory header
6) Create a new physical inventory, enter previously created product
Realize that the Quantity count field is before Order quantity.
If you change the Quantity count field the Order quantity is not modified because the callout is other way around.
Proposed Solution- Make visible this field: Physical Inventory Lines - order quantity
- Move before the Quantity count field because of the callout.

See attached screenshot.
TagsNo tags attached.
Attached Filespng file icon Physical inventory in 2.50.png [^] (40,505 bytes) 2011-10-19 10:41

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0044101)
hgbot (developer)
2012-01-03 13:53

Repository: erp/devel/pi
Changeset: 034b948649c978276d7b9c8f422eb6069f1c8706
Author: Ioritz Cia <ioritz.cia <at> openbravo.com>
Date: Fri Dec 16 09:15:09 2011 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/034b948649c978276d7b9c8f422eb6069f1c8706 [^]

Fixes issue 18806: Order unit (secondary unit) - Physical Inventory Lines:
order quantity changes.

---
M modules/org.openbravo.v3/src-db/database/configScript.xml
---
(0044114)
maite (developer)
2012-01-04 12:52

Field's position is not clear enough. "Order Quantity" and "Quantity Count" should be in the same line to avoid errors, and field "Order UOM" should be also displayed.
(0044141)
hgbot (developer)
2012-01-09 11:56

Repository: erp/devel/pi
Changeset: dd8e5b8f8fa67444bdbb1731085b3c609058d84c
Author: Jon Alegría <jon.alegria <at> openbravo.com>
Date: Mon Jan 09 11:55:28 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/dd8e5b8f8fa67444bdbb1731085b3c609058d84c [^]

Fixes issue 0018806: Order unit (secondary unit) - Physical Inventory Lines:
order quantity changes.
New order to the fields and now order UOM is shown.

---
M modules/org.openbravo.v3/src-db/database/configScript.xml
---
(0044166)
maite (developer)
2012-01-10 10:51

verified
(0044285)
hudsonbot (developer)
2012-01-12 10:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e05372cda9e0 [^]

Maturity status: Test
(0044291)
hudsonbot (developer)
2012-01-12 10:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e05372cda9e0 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-10-19 10:41 mirurita New Issue
2011-10-19 10:41 mirurita Assigned To => jonalegriaesarte
2011-10-19 10:41 mirurita File Added: Physical inventory in 2.50.png
2011-10-19 10:41 mirurita Modules => Core
2011-10-19 11:49 mirurita Target Version => 3.0MP7
2011-12-13 13:13 jonalegriaesarte Assigned To jonalegriaesarte => umartirena
2011-12-13 16:18 ioritzCia Assigned To umartirena => ioritzCia
2011-12-30 10:25 jonalegriaesarte Target Version 3.0MP7 => 3.0MP8
2012-01-03 13:53 hgbot Checkin
2012-01-03 13:53 hgbot Note Added: 0044101
2012-01-03 13:53 hgbot Status new => resolved
2012-01-03 13:53 hgbot Resolution open => fixed
2012-01-03 13:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/034b948649c978276d7b9c8f422eb6069f1c8706 [^]
2012-01-04 12:52 maite Note Added: 0044114
2012-01-04 12:52 maite Status resolved => new
2012-01-04 12:52 maite Resolution fixed => open
2012-01-09 11:56 hgbot Checkin
2012-01-09 11:56 hgbot Note Added: 0044141
2012-01-09 11:56 hgbot Status new => resolved
2012-01-09 11:56 hgbot Resolution open => fixed
2012-01-09 11:56 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/034b948649c978276d7b9c8f422eb6069f1c8706 [^] => http://code.openbravo.com/erp/devel/pi/rev/dd8e5b8f8fa67444bdbb1731085b3c609058d84c [^]
2012-01-10 10:51 maite Note Added: 0044166
2012-01-10 10:51 maite Status resolved => closed
2012-01-12 10:26 hudsonbot Checkin
2012-01-12 10:26 hudsonbot Note Added: 0044285
2012-01-12 10:26 hudsonbot Checkin
2012-01-12 10:26 hudsonbot Note Added: 0044291


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker