Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0018530
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionaryminoralways2011-09-15 09:492012-03-02 15:38
ReporteregoitzView Statuspublic 
Assigned Tomarvintm 
PriorityhighResolutionfixedFixed in Version3.0MP9
StatusclosedFix in branchFixed in SCM revision6549cff0fa4b
ProjectionnoneETAnoneTarget Version3.0MP9
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP2.2SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0018530: The image field on product window has an incorrect reference.

DescriptionThe product table as an image column (ad_image_id) using image reference when in Openbravo3 the proper reference is imageblob.
Steps To ReproduceCheck the definition on the application dictionary of ad_image_Id column on m_product table
Proposed Solution-Change the reference from image to imageblob
-PUt the fields visible and located on the proper position
-Add a tool on the migration tool to move images from old reference to the new one.
TagsNo tags attached.
Attached Filesdiff file icon convertimages.diff [^] (4,613 bytes) 2011-12-21 11:26 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0018496 closedadrianromero Modules The job to synchronize products does not allow imageblob reference 

-  Notes
(0044881)
hgbot (developer)
2012-02-06 10:22

Repository: erp/devel/pi
Changeset: ce1acb5ef9dd40d7bcf47735023f9208193f1c5d
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Feb 06 09:58:07 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ce1acb5ef9dd40d7bcf47735023f9208193f1c5d [^]

Fixed issue 18530. Changed reference of the product image. Added modulescript to convert images.

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_FIELD.xml
A src-util/modulescript/build/classes/org/openbravo/modulescript/ConvertImages.class
A src-util/modulescript/src/org/openbravo/modulescript/ConvertImages.java
---
(0044969)
marvintm (developer)
2012-02-09 16:22

Test plan:

Two things need to be tested:
- Verify that the image in the product window works correctly, and that images can be uploaded to products without problems.
- Verify that the modulescript works: for this, define via database access some images (in the old way, by creating a record in ad_image, specifying a valid URL, and manually moving the image files to the folder inside Tomcat). After this, run ant update.database and verify that the modulescript correctly imports the image data into the database, and that the images are shown in the product window.
(0045010)
hgbot (developer)
2012-02-10 16:03

Repository: erp/devel/pi
Changeset: 3cd3c4f08a8f0dc4325ca38986fc84f3d46bde17
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Feb 10 16:01:00 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3cd3c4f08a8f0dc4325ca38986fc84f3d46bde17 [^]

Related to issue 18530. Modulescript will now log error messages. Use CATALINA_HOME if there is no CATALINA_BASE. Removed wrong import.

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/ConvertImages.class
M src-util/modulescript/src/org/openbravo/modulescript/ConvertImages.java
---
(0045015)
hgbot (developer)
2012-02-10 16:43

Repository: erp/devel/pi
Changeset: bb8f1d8ffd6727db0712b8a4177d77012532fcaf
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Fri Feb 10 16:41:45 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/bb8f1d8ffd6727db0712b8a4177d77012532fcaf [^]

Related to issue 18530. Improved error message.

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/ConvertImages.class
M src-util/modulescript/src/org/openbravo/modulescript/ConvertImages.java
---
(0045128)
dbaz (developer)
2012-02-14 18:25

No image field is shown in "Product" window @ changeset 15475 - 215fbb471eaa
(0045129)
hgbot (developer)
2012-02-14 18:32

Repository: erp/devel/pi
Changeset: e319ba9996d63c774cb3689a0f8d6a6548ba9986
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Tue Feb 14 18:31:45 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e319ba9996d63c774cb3689a0f8d6a6548ba9986 [^]

Fixed issue 18530. Mark image field as displayed

---
M modules/org.openbravo.v3/src-db/database/configScript.xml
---
(0045131)
dbaz (developer)
2012-02-14 18:59

Code-review: mimetype column should be filled too in the modulescript to avoid problems and consolidate all the images in the AD in the same way.
(0045185)
hgbot (developer)
2012-02-16 12:12

Repository: erp/devel/pi
Changeset: eb48f353d1d3ee2df696d828b9cf0553d672446f
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Thu Feb 16 10:46:50 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/eb48f353d1d3ee2df696d828b9cf0553d672446f [^]

Fixed issue 18530. Mime type will be computed for the converted images

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/ConvertImages.class
M src-util/modulescript/src/org/openbravo/modulescript/ConvertImages.java
---
(0045204)
dmitry_mezentsev (developer)
2012-02-16 20:04

Hey Guys,

Questions.
Why is this product field located in this place?
Why did it move Production and Process Plan?
Do you like new layout?
(0045222)
marvintm (developer)
2012-02-17 10:15

Hi,

I put it there because I didn't want to put it in the upper-left corner (as that would imply moving all the fields, including the organization field which in our standard is always the first field). I thought that in the current place it didn't look bad.

However, I'm certainly open to any suggestions. Styling is not my forte :)
(0045253)
dbaz (developer)
2012-02-18 22:16
edited on: 2012-02-18 23:23

The AD_IMAGE column "name" value should be changed to "Image" too in order to be coherent with the other existing fields.

This could help future developments, such as define a new name "ImageURL" or whatever to distinguish the type of the image.

(0045264)
hgbot (developer)
2012-02-20 11:10

Repository: erp/devel/pi
Changeset: 6549cff0fa4b7023d030feef32a293907c9a36c7
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Feb 20 11:09:18 2012 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6549cff0fa4b7023d030feef32a293907c9a36c7 [^]

Fixed issue 18530. Set the name of the image.

---
M src-util/modulescript/build/classes/org/openbravo/modulescript/ConvertImages.class
M src-util/modulescript/src/org/openbravo/modulescript/ConvertImages.java
---
(0045291)
dbaz (developer)
2012-02-20 20:49

Reviewed @ changeset 15549 - 2318a06cc636
(0045759)
hudsonbot (developer)
2012-03-02 15:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test
(0045797)
hudsonbot (developer)
2012-03-02 15:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test
(0045801)
hudsonbot (developer)
2012-03-02 15:35

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test
(0045850)
hudsonbot (developer)
2012-03-02 15:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test
(0045868)
hudsonbot (developer)
2012-03-02 15:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test
(0045892)
hudsonbot (developer)
2012-03-02 15:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/544d64e0c159 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-09-15 09:49 egoitz New Issue
2011-09-15 09:49 egoitz Assigned To => marvintm
2011-09-15 09:49 egoitz Modules => Core
2011-09-15 09:49 egoitz Relationship added related to 0018496
2011-09-26 17:53 marvintm Target Version 3.0MP4 => 3.0MP5
2011-10-26 17:35 marvintm Target Version 3.0MP5 => 3.0MP6
2011-11-22 17:38 marvintm Target Version 3.0MP6 => 3.0MP7
2011-12-21 11:26 marvintm File Added: convertimages.diff
2011-12-21 11:27 marvintm Target Version 3.0MP7 => 3.0MP8
2012-01-17 10:02 marvintm Target Version 3.0MP8 => 3.0MP9
2012-02-06 10:22 hgbot Checkin
2012-02-06 10:22 hgbot Note Added: 0044881
2012-02-06 10:22 hgbot Status new => resolved
2012-02-06 10:22 hgbot Resolution open => fixed
2012-02-06 10:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ce1acb5ef9dd40d7bcf47735023f9208193f1c5d [^]
2012-02-09 16:22 marvintm Note Added: 0044969
2012-02-10 16:03 hgbot Checkin
2012-02-10 16:03 hgbot Note Added: 0045010
2012-02-10 16:43 hgbot Checkin
2012-02-10 16:43 hgbot Note Added: 0045015
2012-02-14 18:25 dbaz Note Added: 0045128
2012-02-14 18:25 dbaz Status resolved => new
2012-02-14 18:25 dbaz Resolution fixed => open
2012-02-14 18:32 hgbot Checkin
2012-02-14 18:32 hgbot Note Added: 0045129
2012-02-14 18:32 hgbot Status new => resolved
2012-02-14 18:32 hgbot Resolution open => fixed
2012-02-14 18:32 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/ce1acb5ef9dd40d7bcf47735023f9208193f1c5d [^] => http://code.openbravo.com/erp/devel/pi/rev/e319ba9996d63c774cb3689a0f8d6a6548ba9986 [^]
2012-02-14 18:59 dbaz Note Added: 0045131
2012-02-14 18:59 dbaz Status resolved => new
2012-02-14 18:59 dbaz Resolution fixed => open
2012-02-16 12:12 hgbot Checkin
2012-02-16 12:12 hgbot Note Added: 0045185
2012-02-16 12:12 hgbot Status new => resolved
2012-02-16 12:12 hgbot Resolution open => fixed
2012-02-16 12:12 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/e319ba9996d63c774cb3689a0f8d6a6548ba9986 [^] => http://code.openbravo.com/erp/devel/pi/rev/eb48f353d1d3ee2df696d828b9cf0553d672446f [^]
2012-02-16 20:04 dmitry_mezentsev Note Added: 0045204
2012-02-17 10:15 marvintm Note Added: 0045222
2012-02-18 22:16 dbaz Note Added: 0045253
2012-02-18 22:16 dbaz Status resolved => closed
2012-02-18 22:16 dbaz Fixed in Version => 3.0MP9
2012-02-18 23:21 dbaz Status closed => new
2012-02-18 23:21 dbaz Resolution fixed => open
2012-02-18 23:21 dbaz Fixed in Version 3.0MP9 =>
2012-02-18 23:23 dbaz Note Edited: 0045253 View Revisions
2012-02-20 11:10 hgbot Checkin
2012-02-20 11:10 hgbot Note Added: 0045264
2012-02-20 11:10 hgbot Status new => resolved
2012-02-20 11:10 hgbot Resolution open => fixed
2012-02-20 11:10 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/eb48f353d1d3ee2df696d828b9cf0553d672446f [^] => http://code.openbravo.com/erp/devel/pi/rev/6549cff0fa4b7023d030feef32a293907c9a36c7 [^]
2012-02-20 20:49 dbaz Note Added: 0045291
2012-02-20 20:49 dbaz Status resolved => closed
2012-02-20 20:49 dbaz Fixed in Version => 3.0MP9
2012-03-02 15:34 hudsonbot Checkin
2012-03-02 15:34 hudsonbot Note Added: 0045759
2012-03-02 15:35 hudsonbot Checkin
2012-03-02 15:35 hudsonbot Note Added: 0045797
2012-03-02 15:35 hudsonbot Checkin
2012-03-02 15:35 hudsonbot Note Added: 0045801
2012-03-02 15:37 hudsonbot Checkin
2012-03-02 15:37 hudsonbot Note Added: 0045850
2012-03-02 15:37 hudsonbot Checkin
2012-03-02 15:37 hudsonbot Note Added: 0045868
2012-03-02 15:38 hudsonbot Checkin
2012-03-02 15:38 hudsonbot Note Added: 0045892


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker