Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0018149
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2011-08-01 15:412011-10-12 01:58
ReportermtaalView Statuspublic 
Assigned Tomtaal 
PrioritynormalResolutionfixedFixed in Version3.0MP4
StatusclosedFix in branchpiFixed in SCM revision61628b69bbab
ProjectionnoneETAnoneTarget Version3.0MP4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0MP1SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0018149: Field shows error when form is shown

DescriptionWhen the form opens the first field with the focus shows an error (a red label). This even before the user has typed anything.
Steps To ReproduceTo reproduce:
- change role to Sys admin
- go to message window
- press new in form
- the searchkey/value field will show a red label
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0039746)
hgbot (developer)
2011-08-01 15:52

Repository: erp/devel/pi
Changeset: c087bb4d81c2b2fbb4ee4d8c264947c4b7429b04
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Mon Aug 01 15:51:20 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c087bb4d81c2b2fbb4ee4d8c264947c4b7429b04 [^]

Fixes issue 18149: Field shows error when form is shown
This was caused by a blur done when initializing the form, prevented the blur when initializing

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0039924)
hudsonbot (developer)
2011-08-06 05:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5744448753e7 [^]

Maturity status: Test
(0039975)
mtaal (developer)
2011-08-07 18:53

I still saw this happening, in the AD_Message window.
(0040029)
dmitry_mezentsev (developer)
2011-08-09 11:09

As far as I understand it is not happening consistently (has just tried to reproduce and failed to). I also have not seen it so far in the functional windows. So with this and given that MP2 is now frozen I am moving this issue to MP3.
(0041135)
hgbot (developer)
2011-09-20 14:48

Repository: erp/devel/pi
Changeset: 61628b69bbab1b3cc686a2461f1df15a3836776b
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Tue Sep 20 14:47:37 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/61628b69bbab1b3cc686a2461f1df15a3836776b [^]

Fixes issue 18149: Field shows error when form is shown
Clear the errors at the end of opening a new form

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0041225)
mtaal (developer)
2011-09-22 09:55

See it when opening a new example window.
(0041249)
mtaal (developer)
2011-09-23 08:07

.
(0041250)
mtaal (developer)
2011-09-23 08:08

Seems to be resolved, not reproducable after the fix
(0041689)
hudsonbot (developer)
2011-10-12 01:58

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9bd2b5c2d982 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-08-01 15:41 mtaal New Issue
2011-08-01 15:41 mtaal Assigned To => mtaal
2011-08-01 15:41 mtaal Modules => Core
2011-08-01 15:52 hgbot Checkin
2011-08-01 15:52 hgbot Note Added: 0039746
2011-08-01 15:52 hgbot Status new => resolved
2011-08-01 15:52 hgbot Resolution open => fixed
2011-08-01 15:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c087bb4d81c2b2fbb4ee4d8c264947c4b7429b04 [^]
2011-08-06 05:32 hudsonbot Checkin
2011-08-06 05:32 hudsonbot Note Added: 0039924
2011-08-07 18:53 mtaal Note Added: 0039975
2011-08-07 18:53 mtaal Status resolved => new
2011-08-07 18:53 mtaal Resolution fixed => open
2011-08-09 11:09 dmitry_mezentsev Note Added: 0040029
2011-08-09 11:09 dmitry_mezentsev Target Version 3.0MP2 => 3.0MP3
2011-08-31 09:40 mtaal Target Version 3.0MP3 => 3.0MP4
2011-09-20 14:48 hgbot Checkin
2011-09-20 14:48 hgbot Note Added: 0041135
2011-09-20 14:48 hgbot Status new => resolved
2011-09-20 14:48 hgbot Resolution open => fixed
2011-09-20 14:48 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/c087bb4d81c2b2fbb4ee4d8c264947c4b7429b04 [^] => http://code.openbravo.com/erp/devel/pi/rev/61628b69bbab1b3cc686a2461f1df15a3836776b [^]
2011-09-22 09:55 mtaal Note Added: 0041225
2011-09-22 09:55 mtaal Status resolved => new
2011-09-22 09:55 mtaal Resolution fixed => open
2011-09-23 08:07 mtaal Status new => scheduled
2011-09-23 08:07 mtaal Note Added: 0041249
2011-09-23 08:07 mtaal fix_in_branch => pi
2011-09-23 08:08 mtaal Note Added: 0041250
2011-09-23 08:08 mtaal Status scheduled => resolved
2011-09-23 08:08 mtaal Fixed in Version => 3.0MP4
2011-09-23 08:08 mtaal Resolution open => fixed
2011-10-03 10:16 marvintm Status resolved => closed
2011-10-12 01:58 hudsonbot Checkin
2011-10-12 01:58 hudsonbot Note Added: 0041689


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker