Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0018136
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Otherscriticalalways2011-07-29 15:252011-12-15 10:34
ReporterioritzCiaView Statuspublic 
Assigned ToioritzCia 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionfd48ed8aef1d
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_22
OS VersionUbuntu 10.04Database version8.4Ant version1.7.1
Product VersionSCM revision 
Review Assigned To
Web browserMozilla Firefox
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0018136: Issue 17775: try-api fails. Requesting API change.

DescriptionDue to this issue,

- https://issues.openbravo.com/view.php?id=17775 [^]

I have to make an API change. This is the change:

- https://code.openbravo.com/erp/devel/try/rev/4704e93b5a23 [^]

I have pushed the change to try and this is the failure:

- http://builds.openbravo.com/view/try/job/try-api/434/console [^]

- The change is the following:
The ReportTrialBalanceDetail was executing inside ReportTrialBalance process.

- The change is needed due to the following reason:
In 3.0 this forces you to re-open ReportTrialBalance after opening ReportTrialBalanceDetail if you want to execute ReportTrialBalance again because there is not backwards button.

- The risk of this api change is very low because of the following reason:
ReportTrialBalanceDetail's mapping is deleted in ReportTrialBalance's process and a new mapping is created in ReportTrialBalanceDetail's process. The only risk is if someone is developing a module that opens tabs and uses the old mapping for the ReportTrialBalanceDetail. This is very unlikely to happen.
Steps To Reproducenone
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0039558)
dmitry_mezentsev (developer)
2011-08-01 10:57

Approved.
(0039574)
hgbot (developer)
2011-08-01 13:25

Repository: erp/devel/api-checks
Changeset: fd48ed8aef1d2f6bb999d37a2bf570b0558e8816
Author: Ioritz Cia <ioritz.cia <at> openbravo.com>
Date: Mon Aug 01 13:24:10 2011 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/fd48ed8aef1d2f6bb999d37a2bf570b0558e8816 [^]

Fixes issue 18136: Issue 17775: try-api fails. Requesting API change.

---
M model/src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M model/src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
M model/src-db/database/sourcedata/AD_PROCESS.xml
---
(0043886)
ioritzCia (developer)
2011-12-15 10:33

Verified

- Issue History
Date Modified Username Field Change
2011-07-29 15:25 ioritzCia New Issue
2011-07-29 15:25 ioritzCia Assigned To => dmitry_mezentsev
2011-07-29 15:25 ioritzCia Web browser => Mozilla Firefox
2011-07-29 15:25 ioritzCia Modules => Core
2011-08-01 10:57 dmitry_mezentsev Note Added: 0039558
2011-08-01 10:57 dmitry_mezentsev Assigned To dmitry_mezentsev => ioritzCia
2011-08-01 10:57 dmitry_mezentsev Status new => acknowledged
2011-08-01 13:25 hgbot Checkin
2011-08-01 13:25 hgbot Note Added: 0039574
2011-08-01 13:25 hgbot Status acknowledged => resolved
2011-08-01 13:25 hgbot Resolution open => fixed
2011-08-01 13:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/fd48ed8aef1d2f6bb999d37a2bf570b0558e8816 [^]
2011-12-15 10:34 ioritzCia Note Added: 0043886
2011-12-15 10:34 ioritzCia Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker