Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0017205
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementminorhave not tried2011-05-17 16:112011-05-26 07:44
ReporterRenateNieuwkoopView Statuspublic 
Assigned Tomarvintm 
PriorityimmediateResolutionfixedFixed in Version3.0RC7
StatusclosedFix in branchFixed in SCM revisionead0927e415d
ProjectionnoneETAnoneTarget Version3.0RC7
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0017205: Sales order does not display Invoice Terms field for Standard order

DescriptionWhen you enter the Sales Order screen and enter a new Sales order with type Standard Order, the field Invoice Terms is not selectable. I thought this was resolved with issue 16788, but apparantly that was not the same problem.

The work around is to change to a POS Order, then invoice terms then appears and then change the order type to Standard Order again. The Invoice terms field remains visible.
Steps To ReproduceGo to the Sales Order screen and enter a new record. The default is Standard order and the Invoice Terms are not visible.
TagsNo tags attached.
Attached Filespng file icon 170511InvoiceTerms1.png [^] (57,646 bytes) 2011-05-17 16:11

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00167883.0RC7 closedmarvintm Invoice terms is not shown in sales order window 

-  Notes
(0037112)
iperdomo (developer)
2011-05-17 20:15

The issue happens on NEW, due to computation of auxiliar-inputs twice, related to this code:

https://code.openbravo.com/erp/devel/pi/rev/a7235c01dfce [^]

A callout set a value of ORDERTYPE but the computation of aux-input again, resets to the value to empty.
(0037119)
hgbot (developer)
2011-05-18 09:51

Repository: erp/devel/pi
Changeset: ead0927e415d36fb6fab3c5d1bff412e6f7205fc
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed May 18 09:49:45 2011 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ead0927e415d36fb6fab3c5d1bff412e6f7205fc [^]

Fixed issue 17205. Auxiliary Inputs will be recomputed before callouts.
This means that if a callout modifies an auxiliary input value, its execution will override the previously calculated value instead of being overwritten afterwards.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
---
(0037132)
psarobe (manager)
2011-05-18 12:21

Fixed
(0037484)
hudsonbot (developer)
2011-05-26 07:44

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/728387046be6 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-05-17 16:11 RenateNieuwkoop New Issue
2011-05-17 16:11 RenateNieuwkoop Assigned To => psarobe
2011-05-17 16:11 RenateNieuwkoop File Added: 170511InvoiceTerms1.png
2011-05-17 16:11 RenateNieuwkoop Modules => Core
2011-05-17 17:20 psarobe Assigned To psarobe => iperdomo
2011-05-17 17:20 psarobe Status new => scheduled
2011-05-17 17:20 psarobe Target Version 3.0MP7 => 3.0RC7
2011-05-17 20:10 iperdomo Relationship added related to 0016788
2011-05-17 20:15 iperdomo Note Added: 0037112
2011-05-17 20:15 iperdomo Assigned To iperdomo => marvintm
2011-05-18 09:51 hgbot Checkin
2011-05-18 09:51 hgbot Note Added: 0037119
2011-05-18 09:51 hgbot Status scheduled => resolved
2011-05-18 09:51 hgbot Resolution open => fixed
2011-05-18 09:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ead0927e415d36fb6fab3c5d1bff412e6f7205fc [^]
2011-05-18 12:21 psarobe Note Added: 0037132
2011-05-18 12:21 psarobe Status resolved => closed
2011-05-18 12:21 psarobe Fixed in Version => 3.0RC7
2011-05-26 07:44 hudsonbot Checkin
2011-05-26 07:44 hudsonbot Note Added: 0037484


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker