Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0016469
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 07. Sales managementmajoralways2011-03-03 17:272011-04-04 18:43
ReporterxabiermerinoView Statuspublic 
Assigned ToAinhoaPagola 
PriorityurgentResolutionfixedFixed in Version2.50MP29
StatusclosedFix in branch2.50Fixed in SCM revision3432182e4a73
ProjectionnoneETAnoneTarget Version2.50MP28
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version2.50MP27SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0016469: Error when you reactivate an invoice

DescriptionIf you modify a payment of an invoice completed, the C_Invoice_Post does not delete the payment.

When you update the payment, the column 'isautomaticgenerate' from c_debt_payment takes 'N' as value, this is why the process does not delete it.

Steps To Reproduce- As Openbravo Admin go to Sales Invoice
- Create an invoice
- Complete it
- Go to 'Payment in'
- Delete the description and save
- Reactivate the invoice
- Realize that the process does not delete the payment
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00161222.50MP28 closedAinhoaPagola Error when you reactivate an invoice 

-  Notes
(0035365)
AinhoaPagola (reporter)
2011-03-30 12:27

Updating c_debt_payment table sets 'isautomaticgenerate' column to 'N' because the preferences are set this way. There is no default value set for this column.

c_invoice_post function should set this column to 'Y' when creating payments automatically.
(0035439)
hgbot (developer)
2011-04-01 09:11

Repository: erp/stable/2.50
Changeset: 3432182e4a732fc26e158d20dd827bf10caccf95
Author: Ainhoa Pagola <ainhoa.pagola <at> openbravo.com>
Date: Wed Mar 30 12:38:44 2011 +0200
URL: http://code.openbravo.com/erp/stable/2.50/rev/3432182e4a732fc26e158d20dd827bf10caccf95 [^]

Fixes Issue 16469. Payments set to automatically generated in c_invoice_post

---
M src-db/database/model/functions/C_INVOICE_POST.xml
---
(0035570)
xabiermerino (developer)
2011-04-04 18:43

Verified

- Issue History
Date Modified Username Field Change
2011-03-24 17:11 dalsasua Type defect => backport
2011-03-24 17:11 dalsasua fix_in_branch => 2.50
2011-03-30 12:27 AinhoaPagola Note Added: 0035365
2011-04-01 09:11 hgbot Checkin
2011-04-01 09:11 hgbot Note Added: 0035439
2011-04-01 09:11 hgbot Status scheduled => resolved
2011-04-01 09:11 hgbot Resolution open => fixed
2011-04-01 09:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/stable/2.50/rev/3432182e4a732fc26e158d20dd827bf10caccf95 [^]
2011-04-04 18:43 xabiermerino Note Added: 0035570
2011-04-04 18:43 xabiermerino Status resolved => closed
2011-04-04 18:43 xabiermerino Fixed in Version => 2.50MP29


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker