Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0016466
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2011-03-24 13:162012-05-25 12:07
ReportergorkaionView Statuspublic 
Assigned ToSandrahuguet 
PriorityhighResolutionfixedFixed in Version3.0MP12
StatusclosedFix in branchFixed in SCM revision2cdc94732fac
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.5.0_15
OS VersionGentooDatabase version11gAnt version1.7.0
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0016466: referencedData contains translations for es_ES and en_US.

Descriptionthe referencedData folder contains translations for es_ES and en_US.

Shouldn't be the es_ES translations on the spanish translation pack?

Why translations to en_US if core's base language is en_US?

Even if for performance issues makes sense to have en_US translations on the TRL tables. We should ensure that these translations are the same than the original term. For example right now there is "Liter" on C_UOM (core is en_US), with a translation to en_US as "Litre" and to es_ES as "Liter".

TagsVMA-Reviewed
Attached Filespng file icon IssueUOMLiter.png [^] (49,225 bytes) 2012-01-03 15:07

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0040597)
jonalegriaesarte (reporter)
2011-08-31 11:31

Due to the load with other issues we were not able to research this one for MP3, are planning MP4 for it now.
(0044102)
RenateNieuwkoop (developer)
2012-01-03 15:01

further comment to the Liter UOM:
In UK English the word is spelled 'Litre'
In US English the word is spelled 'Liter'
So in the translation tab of the UOM Liter there is supposedly a translation to English (USA) for the spelling 'Litre', but that is incorrect and should be LITER. See screenshot
(0047709)
Sandrahuguet (developer)
2012-04-18 15:53

Test Plan:
-First you must do ant install.source
-Go to Unit if Measure
-Notice that now there are not translations
(0048210)
hgbot (developer)
2012-05-02 09:23

Repository: erp/devel/pi
Changeset: 2cdc94732fac1f6f5fa99afaf3a5df893ce9989f
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Tue Apr 24 18:09:24 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2cdc94732fac1f6f5fa99afaf3a5df893ce9989f [^]

Fixed bug 16466 Remove trl in sourcedata/referencedData
Remove C_UOM_TRL.xml, C_COUNTRY_TRL.xml, C_CURRENCY_TRL.xml,
C _DOCTYPE_TRL.xml andthe table in the dataset,
because this translations are not supported.

---
M referencedata/sampledata/F_B_International_Group.xml
M referencedata/sampledata/QA_Testing.xml
M src-db/database/sourcedata/AD_DATASET_TABLE.xml
R src-db/database/sourcedata/referencedData/C_COUNTRY_TRL.xml
R src-db/database/sourcedata/referencedData/C_CURRENCY_TRL.xml
R src-db/database/sourcedata/referencedData/C_DOCTYPE_TRL.xml
R src-db/database/sourcedata/referencedData/C_UOM_TRL.xml
---
(0048214)
hgbot (developer)
2012-05-02 09:23

Repository: erp/devel/pi
Changeset: 3d5912dcccfa4b1e2438ddea4b4fb7e7dd15a337
Author: Mikel Irurita <mikel.irurita <at> openbravo.com>
Date: Mon Apr 30 17:58:38 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3d5912dcccfa4b1e2438ddea4b4fb7e7dd15a337 [^]

Related to issue 16466: remove c_doctype_trl records from sampledata

---
M referencedata/sampledata/F_B_International_Group.xml
M referencedata/sampledata/QA_Testing.xml
---
(0048217)
hgbot (developer)
2012-05-02 09:25

Repository: erp/devel/api-checks
Changeset: 0e9d527322272314695f0652ff1698f6e1c94b0a
Author: Mikel Irurita <mikel.irurita <at> openbravo.com>
Date: Wed May 02 09:22:19 2012 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/0e9d527322272314695f0652ff1698f6e1c94b0a [^]

Related to issue 16466: API change false positive

---
M model/src-db/database/sourcedata/AD_DATASET_TABLE.xml
---
(0048251)
mirurita (developer)
2012-05-02 18:38

code review + testing OK
(0048929)
hudsonbot (developer)
2012-05-25 12:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5401e185a8b0 [^]

Maturity status: Test
(0048933)
hudsonbot (developer)
2012-05-25 12:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5401e185a8b0 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2011-03-24 13:16 gorkaion New Issue
2011-03-24 13:16 gorkaion Assigned To => alostale
2011-03-24 13:16 gorkaion Modules => Core
2011-03-24 13:19 shuehner Issue Monitored: shuehner
2011-03-29 09:13 alostale Target Version 3.0RC6 => 3.0
2011-03-29 09:13 alostale Status new => scheduled
2011-03-29 09:13 alostale fix_in_branch => pi
2011-05-23 14:32 dmitry_mezentsev Priority normal => high
2011-05-23 14:32 dmitry_mezentsev fix_in_branch pi =>
2011-06-02 10:54 dmitry_mezentsev Target Version 3.0MP0 => 3.0MP1
2011-06-22 19:26 dmitry_mezentsev Target Version 3.0MP1 => 3.0MP2
2011-06-22 20:29 dmitry_mezentsev Target Version 3.0MP2 => 3.0MP3
2011-08-31 11:31 jonalegriaesarte Note Added: 0040597
2011-08-31 11:31 jonalegriaesarte Target Version 3.0MP3 => 3.0MP4
2011-09-27 13:03 alostale Target Version 3.0MP4 => 3.0MP5
2011-10-31 14:28 alostale Target Version 3.0MP5 => 3.0MP6
2011-11-15 08:41 alostale Tag Attached: nextMP
2011-11-15 08:56 alostale Target Version 3.0MP6 =>
2012-01-03 15:01 RenateNieuwkoop Note Added: 0044102
2012-01-03 15:07 RenateNieuwkoop File Added: IssueUOMLiter.png
2012-02-22 15:59 alostale Tag Detached: nextMP
2012-02-22 16:00 alostale Assigned To alostale => vmromanos
2012-04-11 12:05 vmromanos Tag Attached: VMA-Reviewed
2012-04-18 11:36 Sandrahuguet Assigned To vmromanos => Sandrahuguet
2012-04-18 15:53 Sandrahuguet Note Added: 0047709
2012-05-02 09:23 hgbot Checkin
2012-05-02 09:23 hgbot Note Added: 0048210
2012-05-02 09:23 hgbot Status scheduled => resolved
2012-05-02 09:23 hgbot Resolution open => fixed
2012-05-02 09:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2cdc94732fac1f6f5fa99afaf3a5df893ce9989f [^]
2012-05-02 09:23 hgbot Checkin
2012-05-02 09:23 hgbot Note Added: 0048214
2012-05-02 09:25 hgbot Checkin
2012-05-02 09:25 hgbot Note Added: 0048217
2012-05-02 18:38 mirurita Note Added: 0048251
2012-05-02 18:38 mirurita Status resolved => closed
2012-05-02 18:38 mirurita Fixed in Version => 3.0MP12
2012-05-25 12:07 hudsonbot Checkin
2012-05-25 12:07 hudsonbot Note Added: 0048929
2012-05-25 12:07 hudsonbot Checkin
2012-05-25 12:07 hudsonbot Note Added: 0048933


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker