Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0016452
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformmajoralways2011-03-23 17:572014-10-10 13:40
ReporteriperdomoView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision9e21670a1191
ProjectionnoneETAnoneTarget Version
OSWindowsDatabasePostgreSQLJava version1.6.0_14
OS VersionXPDatabase version8.3.7Ant version1.7.1
Product Version3.0RC4SCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0016452: On Windows: The application won't start if the installation path contains a blank

DescriptionWARN org.jboss.weld.environment.servlet.deployment.URLScanner - could not read entries

java.io.FileNotFoundException: C:\Program%20Files\Apache\apache-tomcat-6.0.29\we
bapps\openbravo3\WEB-INF\classes (El sistema no puede encontrar la ruta especifi
cada)
Steps To Reproduce* Using Win32 based system, try to install and deploy Openbravo 3 on an installation path containing blanks e.g. C:\Program Files\Apache\Apache Tomcat\
TagsNo tags attached.
Attached Filestxt file icon errorwindows.txt [^] (13,392 bytes) 2011-07-06 18:15 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on feature request 0027245 closedalostale upgrade weld 

-  Notes
(0038904)
shuehner (administrator)
2011-07-06 17:59

This might be that upstream issue:
https://issues.jboss.org/browse/WELD-834 [^]
(0038906)
adrianromero (manager)
2011-07-06 18:20

Full trace of the error in file attached.

The error is thrown in the same method and for the same reasond that the issue 834 reported in Weld issue tracker that is planned to be fixed in Weld version 1.1.2.Final. Openbravo MP0 is currently using 1.1.Final
(0038975)
adrianromero (manager)
2011-07-11 14:28

It is confirmed that this issue is in the Weld library version used 1.1-Final. It will be resolved when the new Weld version 1.1.2-Final is relased and we replace it in Openbravo ERP
(0044557)
iperdomo (developer)
2012-01-25 13:47

Adding MP9 as target release since is a "risky" release
(0044908)
marvintm (developer)
2012-02-07 15:52

This issue has not been fixed in Weld, as of version 1.1.5:

https://issues.jboss.org/browse/WELD-1028 [^]

and we cannot fix this until this weld issue has been resolved.
(0052455)
AugustoMauch (developer)
2012-09-24 23:21

Impact: mid
Plan: short
(0070835)
alostale (developer)
2014-10-09 11:21

Fixed by issue 0027245

Tested in Windows 7
(0070873)
AugustoMauch (developer)
2014-10-10 13:40

Code reviewed and verified in pi@9e21670a1191

- Issue History
Date Modified Username Field Change
2011-03-23 17:57 iperdomo New Issue
2011-03-23 17:57 iperdomo Assigned To => mtaal
2011-03-23 17:57 iperdomo Modules => Core
2011-03-29 09:18 alostale Status new => scheduled
2011-04-04 10:24 mtaal Target Version 3.0RC6 => 3.0RC7
2011-04-04 10:24 mtaal Description Updated View Revisions
2011-05-06 17:44 shuehner Issue Monitored: shuehner
2011-05-10 13:43 mtaal Target Version 3.0RC7 => 3.0MP0
2011-05-17 09:15 iperdomo Priority urgent => normal
2011-05-23 13:22 mtaal Target Version 3.0MP0 => 3.0MP1
2011-06-22 19:57 dmitry_mezentsev Target Version 3.0MP1 => 3.0MP2
2011-06-30 12:23 iperdomo Assigned To mtaal => adrianromero
2011-07-06 17:59 shuehner Note Added: 0038904
2011-07-06 18:15 adrianromero File Added: errorwindows.txt
2011-07-06 18:20 adrianromero Note Added: 0038906
2011-07-11 14:28 adrianromero Note Added: 0038975
2011-07-11 14:28 adrianromero Status scheduled => acknowledged
2011-07-13 12:47 iperdomo Target Version 3.0MP2 =>
2011-09-21 12:32 mtaal Target Version => 3.0MP5
2011-10-31 14:01 dmitry_mezentsev Assigned To adrianromero => alostale
2011-10-31 14:01 dmitry_mezentsev Target Version 3.0MP5 => 3.0MP6
2011-11-15 08:41 alostale Tag Attached: nextMP
2011-11-15 08:56 alostale Target Version 3.0MP6 =>
2011-11-17 18:15 alostale Tag Detached: nextMP
2012-01-25 13:47 iperdomo Note Added: 0044557
2012-01-25 13:47 iperdomo Fixed in Version => 3.0MP9
2012-01-26 09:58 alostale Assigned To alostale => marvintm
2012-02-07 15:52 marvintm Note Added: 0044908
2012-02-07 15:52 marvintm Fixed in Version 3.0MP9 =>
2012-05-08 12:45 alostale Type defect => design defect
2012-09-24 23:21 AugustoMauch Note Added: 0052455
2012-09-24 23:21 AugustoMauch Priority normal => high
2012-09-24 23:21 AugustoMauch Status acknowledged => scheduled
2014-07-31 08:53 alostale Relationship added depends on 0027245
2014-10-07 10:29 alostale Assigned To marvintm => alostale
2014-10-09 11:21 alostale Note Added: 0070835
2014-10-09 11:21 alostale Status scheduled => resolved
2014-10-09 11:21 alostale Fixed in Version => 3.0PR15Q1
2014-10-09 11:21 alostale Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9e21670a1191ce708572b7d61f3c0d8610c590d6 [^]
2014-10-09 11:21 alostale Resolution open => fixed
2014-10-09 11:22 alostale Review Assigned To => AugustoMauch
2014-10-10 13:40 AugustoMauch Note Added: 0070873
2014-10-10 13:40 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker