Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0015854
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2011-02-03 11:352011-02-04 00:00
ReporteriperdomoView Statuspublic 
Assigned Toiperdomo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision94324e221724
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_22
OS Version2.6.35-gentoo-r12Database version8.3.12Ant version1.7.1
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0015854: API model chage - Removed the CacheFilter from AD_Model_Object

Description
The CacheFilter was removed from the application. Now the 'Expires' header is handled by the server, either httpd or tomcat.


 [checkAPI] 42675 ERROR - +++++++++++++++++++++++++++++++++++++++++++++++++++
 [checkAPI] 42680 ERROR - Errors in API data validation
 [checkAPI] 42685 ERROR - +++++++++++++++++++++++++++++++++++++++++++++++++++
 [checkAPI] 42690 ERROR - Removed row from table AD_MODEL_OBJECT - ID: 88420DFF1C6D48A18800FB91A91362AA
 [checkAPI] 42695 ERROR - Removed row from table AD_MODEL_OBJECT_MAPPING - ID: 4B5DCF738C084B0C8FE227E397B86642
 [checkAPI] 42699 ERROR - Removed row from table AD_MODEL_OBJECT_PARA - ID: 4B1DCE7DFC134EA2BECCFD2252189F1C
 [checkAPI] 42704 ERROR -
Steps To ReproduceCheck the API build 1027

http://builds.openbravo.com/job/int-api/1027/console [^]
Proposed SolutionApprove the change
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 00153803.0MP0 closediperdomo Remove tomcat's Expires filter 

-  Notes
(0034026)
iperdomo (developer)
2011-02-03 11:45
edited on: 2011-02-03 11:48

The CacheFilter was adding the 'Expires' to some date in 2038, since the Mayan predicted that the world will end in 2012, makes no sense to have this filter ;)

Note: The real technical explanation is in the associated issue 0015380

(0034028)
iperdomo (developer)
2011-02-03 12:22
edited on: 2011-02-03 12:23

The risk of this to break any published module is zero. We are just removing the usage of the filter. The Expires header is managed by tomcat or httpd

(0034033)
iciordia (manager)
2011-02-03 12:41

Approved.

Ismael
(0034035)
hgbot (developer)
2011-02-03 12:43

Repository: erp/devel/api-checks
Changeset: 94324e221724ff0adff8518653d3004ef72d989e
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Thu Feb 03 12:41:19 2011 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/94324e221724ff0adff8518653d3004ef72d989e [^]

Fixes issue 15854: Removed AD_Model_Object entries

---
M model/src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M model/src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
M model/src-db/database/sourcedata/AD_MODEL_OBJECT_PARA.xml
---
(0034038)
iperdomo (developer)
2011-02-03 14:02

http://builds.openbravo.com/job/int-api/1029/console [^]

- Issue History
Date Modified Username Field Change
2011-02-03 11:35 iperdomo New Issue
2011-02-03 11:35 iperdomo Assigned To => iciordia
2011-02-03 11:35 iperdomo Modules => Core
2011-02-03 11:37 iperdomo Relationship added related to 0015380
2011-02-03 11:44 jpabloae Issue Monitored: jpabloae
2011-02-03 11:45 iperdomo Note Added: 0034026
2011-02-03 11:48 iperdomo Note Edited: 0034026 View Revisions
2011-02-03 12:22 iperdomo Note Added: 0034028
2011-02-03 12:23 iperdomo Note Edited: 0034028 View Revisions
2011-02-03 12:41 iciordia Note Added: 0034033
2011-02-03 12:41 iciordia Assigned To iciordia => iperdomo
2011-02-03 12:43 hgbot Checkin
2011-02-03 12:43 hgbot Note Added: 0034035
2011-02-03 12:43 hgbot Status new => resolved
2011-02-03 12:43 hgbot Resolution open => fixed
2011-02-03 12:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/94324e221724ff0adff8518653d3004ef72d989e [^]
2011-02-03 14:02 iperdomo Note Added: 0034038
2011-02-03 14:02 iperdomo Status resolved => closed
2011-02-04 00:00 anonymous sf_bug_id 0 => 3172097


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker