Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0015573
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Otherscriticalhave not tried2011-01-04 19:172011-01-06 00:00
ReportershuehnerView Statuspublic 
Assigned Tomtaal 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionf03bbe9b03ce
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0015573: api-check 734 fails

DescriptionThis api-check build fails:
http://builds.openbravo.com/job/int-api/734/console [^]


org.openbravo.client.application.window:
Abs.add
method org.openbravo.client.application.window.OBViewFormComponent.OBViewFieldDefinition.getTargetEntity(): new interface method in /srv/hudson/workspace/int-full-oracle/SANDBOX/api-checks/output/734
method org.openbravo.client.application.window.OBViewFormComponent.OBViewFieldDefinition.isParentProperty(): new interface method in /srv/hudson/workspace/int-full-oracle/SANDBOX/api-checks/output/734

Adding new methods to an interface definition will break existing classes implementing that interface as they need to be extended to implement the newly added methods.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0033526)
mtaal (developer)
2011-01-04 19:26

This interface is in reality internal and can be made private. It is part of code which is not discussed in public and code which can not in anyway be meaningfully be extended.

Afaics there is no risk at all in changing this interface. I propose to make it private as part of this issue.

gr. Martin
(0033528)
iciordia (manager)
2011-01-05 09:41

Agree, let's make private that interface. API change approved since there is no risk of any module using it.

Ismael
(0033531)
hgbot (developer)
2011-01-05 15:34

Repository: erp/devel/api-checks
Changeset: f03bbe9b03ce76c7187f483c961cfee7c3c77b21
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Wed Jan 05 15:28:40 2011 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/f03bbe9b03ce76c7187f483c961cfee7c3c77b21 [^]

Fixes issue 15578, Fixes issue 15573

---
M java/reference/java.japi.gz
---
(0033533)
shuehner (administrator)
2011-01-05 18:59

api-check fine -> closing

- Issue History
Date Modified Username Field Change
2011-01-04 19:17 shuehner New Issue
2011-01-04 19:17 shuehner Assigned To => mtaal
2011-01-04 19:17 shuehner Modules => Core
2011-01-04 19:26 mtaal Note Added: 0033526
2011-01-04 19:26 mtaal Assigned To mtaal => iciordia
2011-01-05 09:41 iciordia Note Added: 0033528
2011-01-05 09:41 iciordia Assigned To iciordia => mtaal
2011-01-05 15:34 hgbot Checkin
2011-01-05 15:34 hgbot Note Added: 0033531
2011-01-05 15:34 hgbot Status new => resolved
2011-01-05 15:34 hgbot Resolution open => fixed
2011-01-05 15:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/f03bbe9b03ce76c7187f483c961cfee7c3c77b21 [^]
2011-01-05 18:59 shuehner Note Added: 0033533
2011-01-05 18:59 shuehner Status resolved => closed
2011-01-06 00:00 anonymous sf_bug_id 0 => 3152156


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker