Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0012234
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Otherscriticalhave not tried2010-02-11 14:252010-03-10 18:29
ReportershuehnerView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version2.50MP12
StatusclosedFix in branchpiFixed in SCM revision591179891aba
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0012234: api check build 288 fails

Descriptionhttp://builds.openbravo.com/job/erp_devel_pi-module-integrity-test/288/console [^]


 [checkAPI] +++++++++++++++++++++++++++++++++++++++++++++++++++
 [checkAPI] Errors in API data validation
 [checkAPI] +++++++++++++++++++++++++++++++++++++++++++++++++++
 [checkAPI] Removed row from table AD_MESSAGE - ID: 1299B933978E465AB8D9E73B85F10A1A

The pi-reference branch reintegration removed one ad_message row.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0024171)
mtaal (developer)
2010-02-11 14:33

It is apparently this message, but I can't easy see which change removed it.

<!--1299B933978E465AB8D9E73B85F10A1A--><AD_MESSAGE>
<!--1299B933978E465AB8D9E73B85F10A1A--> <AD_MESSAGE_ID><![CDATA[1299B933978E465AB8D9E73B85F10A1A]]></AD_MESSAGE_ID>
<!--1299B933978E465AB8D9E73B85F10A1A--> <AD_CLIENT_ID><![CDATA[0]]></AD_CLIENT_ID>
<!--1299B933978E465AB8D9E73B85F10A1A--> <AD_ORG_ID><![CDATA[0]]></AD_ORG_ID>
<!--1299B933978E465AB8D9E73B85F10A1A--> <ISACTIVE><![CDATA[Y]]></ISACTIVE>
<!--1299B933978E465AB8D9E73B85F10A1A--> <VALUE><![CDATA[20535]]></VALUE>
<!--1299B933978E465AB8D9E73B85F10A1A--> <MSGTEXT><![CDATA[New datatype references are not allowed in modules.]]></MSGTEXT>
<!--1299B933978E465AB8D9E73B85F10A1A--> <MSGTYPE><![CDATA[E]]></MSGTYPE>
<!--1299B933978E465AB8D9E73B85F10A1A--> <AD_MODULE_ID><![CDATA[0]]></AD_MODULE_ID>
<!--1299B933978E465AB8D9E73B85F10A1A--></AD_MESSAGE>
(0024172)
shuehner (administrator)
2010-02-11 14:46

changeset: 6114:b2de9211f7a7
user: Asier Lostalé <asier.lostale@openbravo.com>
date: Mon Nov 30 13:21:02 2009 +0100
files: src-db/database/model/triggers/AD_REFERENCE_TRG3.xml src-db/database/sourcedata/AD_MESSAGE.xml
description:
[reference] Allow creation of base references in modules
(0024174)
alostale (developer)
2010-02-11 15:56

The error message "New datatype references are not allowed in modules" was displayed when a user tried to add a new reference of data type within a module, this has been removed in the extensible references project, because now modules can add any kind of reference.
(0024180)
pjuvara (reporter)
2010-02-11 18:54

Exception accepted.

Please publish alert and add to the list.

Risk level: low.
(0024189)
hgbot (developer)
2010-02-12 07:58

Repository: erp/devel/api-checks
Changeset: 591179891aba54f0eb396486cf37ef405eed5480
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Feb 12 07:58:47 2010 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/591179891aba54f0eb396486cf37ef405eed5480 [^]

fixed issue 12234: api check build 288 fails

---
M model/sourcedata/AD_MESSAGE.xml
---

- Issue History
Date Modified Username Field Change
2010-02-11 14:25 shuehner New Issue
2010-02-11 14:25 shuehner Assigned To => mtaal
2010-02-11 14:33 mtaal Note Added: 0024171
2010-02-11 14:46 shuehner Note Added: 0024172
2010-02-11 14:46 shuehner Assigned To mtaal => alostale
2010-02-11 15:56 alostale Note Added: 0024174
2010-02-11 15:56 alostale Assigned To alostale => pjuvara
2010-02-11 18:54 pjuvara Status new => scheduled
2010-02-11 18:54 pjuvara Note Added: 0024180
2010-02-11 18:54 pjuvara Assigned To pjuvara => alostale
2010-02-11 18:54 pjuvara fix_in_branch => pi
2010-02-12 07:58 hgbot Checkin
2010-02-12 07:58 hgbot Note Added: 0024189
2010-02-12 07:58 hgbot Status scheduled => resolved
2010-02-12 07:58 hgbot Resolution open => fixed
2010-02-12 07:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/591179891aba54f0eb396486cf37ef405eed5480 [^]
2010-02-12 08:03 alostale Status resolved => closed
2010-02-12 08:03 alostale Fixed in Version => 2.50MP12
2010-02-13 00:01 anonymous sf_bug_id 0 =>
2010-03-10 18:29 anonymous sf_bug_id => 2968052


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker