Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0012183
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementtrivialhave not tried2010-02-09 10:312012-04-28 02:31
ReporterRenateNieuwkoopView Statuspublic 
Assigned Tonaiaramartinez 
PrioritynormalResolutionfixedFixed in Version3.0MP11
StatusclosedFix in branchpiFixed in SCM revision85d333e1b119
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version2.50MP11SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0012183: Decimals appearing in the Org Specific tab for leadtime and safety stock make no sense

DescriptionMaster Data Management || Product || Product >> Org Specific

For the fields 'Minimum Lead Time' and 'Safety Stock' the fields now have decimals, where before they didn't. Since it doesn't make any sense for these values to have decimals (and esthetically also since the rest of the fields do not have decimals) I suggest to remove the decimals again.

See snapshot.
TagsVMA-Reviewed
Attached Filespng file icon 090210decimalsinOrgSpecific.png [^] (64,905 bytes) 2010-02-09 10:31


png file icon 090210DecimalsOrgSpecific2.png [^] (57,611 bytes) 2010-02-09 11:11

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0020344 closednaiaramartinez API CHANGE: Change 'Minimum Lead Time' type 

-  Notes
(0024047)
RenateNieuwkoop (developer)
2010-02-09 11:11

Actually also the capacity field has decimals, see snapshot 2
(0047541)
naiaramartinez (developer)
2012-04-12 17:52

Test Plan:
  Go to Product window.
  Select a record.
  Go to manufacturing tab.
  Create new record and set a value in Minimun Lead Time field.
  Save the record.

  Notice that there are no decimals in that field.
(0047542)
naiaramartinez (developer)
2012-04-12 17:55

The decimals of 'Safety Stock' haven't been removed because it can make sense. Imagine the situations where the stock is calculated with kg. The Safety Stock can have decimals.
(0048052)
hgbot (developer)
2012-04-26 17:16

Repository: erp/devel/pi
Changeset: 85d333e1b119b459ca9e66a784f4db8bcc0b49b5
Author: Naiara Martinez <naiara.martinez <at> openbravo.com>
Date: Thu Apr 12 17:43:28 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/85d333e1b119b459ca9e66a784f4db8bcc0b49b5 [^]

fixed bug 12183 Remove decimals in Minimum Lead Time field(Manufacturing tab)

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0048059)
vmromanos (developer)
2012-04-26 17:46

code review + testing OK
(0048162)
hudsonbot (developer)
2012-04-28 02:31

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/cd923b317af4 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2010-02-09 10:31 RenateNieuwkoop New Issue
2010-02-09 10:31 RenateNieuwkoop Assigned To => rafaroda
2010-02-09 10:31 RenateNieuwkoop File Added: 090210decimalsinOrgSpecific.png
2010-02-09 11:11 RenateNieuwkoop Note Added: 0024047
2010-02-09 11:11 RenateNieuwkoop File Added: 090210DecimalsOrgSpecific2.png
2010-02-11 17:55 rafaroda Assigned To rafaroda => adrianromero
2011-06-03 11:00 dalsasua Assigned To adrianromero => dalsasua
2011-07-20 18:11 dalsasua Assigned To dalsasua => jonalegriaesarte
2012-04-03 12:21 jonalegriaesarte Assigned To jonalegriaesarte => vmromanos
2012-04-10 13:34 vmromanos Tag Attached: VMA-Reviewed
2012-04-12 17:44 naiaramartinez Assigned To vmromanos => naiaramartinez
2012-04-12 17:45 naiaramartinez Status new => scheduled
2012-04-12 17:45 naiaramartinez fix_in_branch => pi
2012-04-12 17:52 naiaramartinez Note Added: 0047541
2012-04-12 17:55 naiaramartinez Note Added: 0047542
2012-04-25 09:01 naiaramartinez Relationship added related to 0020344
2012-04-26 17:16 hgbot Checkin
2012-04-26 17:16 hgbot Note Added: 0048052
2012-04-26 17:16 hgbot Status scheduled => resolved
2012-04-26 17:16 hgbot Resolution open => fixed
2012-04-26 17:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/85d333e1b119b459ca9e66a784f4db8bcc0b49b5 [^]
2012-04-26 17:46 vmromanos Note Added: 0048059
2012-04-26 17:46 vmromanos Status resolved => closed
2012-04-26 17:46 vmromanos Fixed in Version => 3.0MP11
2012-04-28 02:31 hudsonbot Checkin
2012-04-28 02:31 hudsonbot Note Added: 0048162


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker