Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0011418
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Otherscriticalhave not tried2009-11-19 14:462009-11-21 00:00
ReportershuehnerView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Version2.50MP9
StatusclosedFix in branchpiFixed in SCM revision9f6f92dcd7c1
ProjectionnoneETAnoneTarget Version2.50MP9
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0011418: api checkbuild 210 fails

DescriptionThis api check build fails:

http://builds.openbravo.com/job/erp_devel_pi-module-integrity-test/210/console [^]

This issue track the following problem:
  Unique constraint modified, column removed: table: C_PERIOD - Unique constraint: C_PERIOD_UNIQUE_PERIOD - removed column AD_CLIENT_ID
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00112582.50MP9 closedvmromanos It is not possible to create a new calendar for an Organization 

-  Notes
(0022016)
shuehner (administrator)
2009-11-19 14:49

Could be a problem if existing data in c_period is valid with old unique constraint and not valid with new one.
@victor: can this happen? or does the new c_year_id indirectly contain the ad_client_id also?
(0022025)
vmromanos (developer)
2009-11-19 16:02
edited on: 2009-11-19 16:09

Stefan,
It can't happen because, as you are saying, C_Year_ID already contains AD_CLIENT_ID

(0022038)
pjuvara (reporter)
2009-11-19 21:54

Approved.
(0022044)
hgbot (developer)
2009-11-20 09:32

Repository: erp/devel/api-checks
Changeset: 9f6f92dcd7c18b3f43287139627ef30bf45f8745
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Fri Nov 20 09:32:50 2009 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/9f6f92dcd7c18b3f43287139627ef30bf45f8745 [^]

Fixed bug 11418: api checkbuild 210 fails

---
M model/model/tables/C_PERIOD.xml
---

- Issue History
Date Modified Username Field Change
2009-11-19 14:46 shuehner New Issue
2009-11-19 14:46 shuehner Assigned To => vmromanos
2009-11-19 14:47 shuehner Relationship added related to 0011258
2009-11-19 14:49 shuehner Note Added: 0022016
2009-11-19 14:49 shuehner Target Version => 2.50MP9
2009-11-19 16:02 vmromanos Note Added: 0022025
2009-11-19 16:07 vmromanos Assigned To vmromanos => pjuvara
2009-11-19 16:09 vmromanos Note Edited: 0022025
2009-11-19 21:54 pjuvara Status new => scheduled
2009-11-19 21:54 pjuvara Note Added: 0022038
2009-11-19 21:54 pjuvara Assigned To pjuvara => vmromanos
2009-11-19 21:54 pjuvara fix_in_branch => pi
2009-11-20 06:11 priyam Issue Monitored: priyam
2009-11-20 09:32 hgbot Checkin
2009-11-20 09:32 hgbot Note Added: 0022044
2009-11-20 09:32 hgbot Status scheduled => resolved
2009-11-20 09:32 hgbot Resolution open => fixed
2009-11-20 09:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/9f6f92dcd7c18b3f43287139627ef30bf45f8745 [^]
2009-11-20 09:33 vmromanos Status resolved => closed
2009-11-20 09:33 vmromanos Fixed in Version => 2.50MP9
2009-11-21 00:00 anonymous sf_bug_id 0 => 2901479


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker