Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0011188
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2009-10-30 12:282009-11-06 00:00
ReporterpsarobeView Statuspublic 
Assigned Todbaz 
PriorityimmediateResolutionfixedFixed in Version2.50MP9
StatusclosedFix in branchpiFixed in SCM revisionb087ad4ed762
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0011188: Decimal format: Amounts not well calculate if decimal rounds is not properly setup

DescriptionIf you are working with 3 or 4 decimal for pricing but the format.xml is not properly setup in order to allow to have 3 or 4 decimal then there is an inconsistent between price x quantity and the result amount

Scenario
========
Format.xml setup for just having 2 decimals. You create a sales invoice and you enter the price: 1.888; quantity:55 amount:103.84
But after leaving the focus in the price field you have 1.89. So finally you have in the DB:
price:1.89
quantity:55
amount:103.84
But 1.89 x 55= 103.95

So the inconsistency is clear
Steps To Reproduce1. Login as Openbravo/openbravo
2. Create a sales invoice
3. Move to lines and enter for quantity 55
4. Enter for price 1.888
5. the amount will be 1.888x55

But as in the DB will be stored 1.89 (because of the format.xml) the amount should be 1.89x55
Proposed SolutionThe call-out should take into the format and what the final quantity, price will be.

Review and fix all the call-outs in the ERP
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0011226 closeddbaz Decimal format: Amounts not well calculate if decimal rounds is not properly setup 

-  Notes
(0021517)
hgbot (developer)
2009-11-02 18:39

Repository: erp/devel/pi
Changeset: 0c8232e70ac9d8f9e676db2690627aa3e2ddbf28
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Mon Nov 02 18:39:00 2009 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0c8232e70ac9d8f9e676db2690627aa3e2ddbf28 [^]

Fixes issue 11188: Changed the number formatting to onChange event, it occurs before onBlur

---
M web/js/utils.js
---
(0021527)
iperdomo (developer)
2009-11-03 09:59

Reopened due to dbaz code review
(0021535)
hgbot (developer)
2009-11-03 14:03

Repository: erp/devel/pi
Changeset: b087ad4ed762733bfff5d1a6ca253d5fb47aad4f
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Tue Nov 03 14:02:06 2009 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b087ad4ed762733bfff5d1a6ca253d5fb47aad4f [^]

Fixed issue 11188: Now callout math operations are consistent

---
M src/org/openbravo/erpCommon/security/Login_F1.html
M web/js/utils.js
---
(0021602)
arunkumar (reporter)
2009-11-05 12:25

Tested & Working fine.

- Issue History
Date Modified Username Field Change
2009-10-30 12:28 psarobe New Issue
2009-10-30 12:28 psarobe Assigned To => iperdomo
2009-10-30 12:29 psarobe Steps to Reproduce Updated
2009-10-30 12:29 psarobe Status new => scheduled
2009-10-30 12:29 psarobe fix_in_branch => pi
2009-11-02 18:39 hgbot Checkin
2009-11-02 18:39 hgbot Note Added: 0021517
2009-11-02 18:39 hgbot Status scheduled => resolved
2009-11-02 18:39 hgbot Resolution open => fixed
2009-11-02 18:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0c8232e70ac9d8f9e676db2690627aa3e2ddbf28 [^]
2009-11-03 09:59 iperdomo Status resolved => new
2009-11-03 09:59 iperdomo Resolution fixed => open
2009-11-03 09:59 iperdomo Note Added: 0021527
2009-11-03 10:00 iperdomo Assigned To iperdomo => dbaz
2009-11-03 10:00 iperdomo Status new => scheduled
2009-11-03 14:03 hgbot Checkin
2009-11-03 14:03 hgbot Note Added: 0021535
2009-11-03 14:03 hgbot Status scheduled => resolved
2009-11-03 14:03 hgbot Resolution open => fixed
2009-11-03 14:03 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/0c8232e70ac9d8f9e676db2690627aa3e2ddbf28 [^] => http://code.openbravo.com/erp/devel/pi/rev/b087ad4ed762733bfff5d1a6ca253d5fb47aad4f [^]
2009-11-05 12:25 arunkumar Status resolved => closed
2009-11-05 12:25 arunkumar Note Added: 0021602
2009-11-05 12:25 arunkumar Fixed in Version => 2.50MP9
2009-11-06 00:00 anonymous sf_bug_id 0 => 2892914


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker