Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0011069
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2009-10-21 16:422010-03-10 18:28
ReportermalsasuaView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version2.50MP12
StatusclosedFix in branchpiFixed in SCM revision24dce3d8581a
ProjectionnoneETAnoneTarget Version2.50MP12
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_11
OS VersionrPath LinuxDatabase version8.3.5Ant version1.7.1
Product Version2.50MP6SCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0011069: In menu's tree not appear nodes without translate

DescriptionIf you have a node that it does not have translate to language logged, this nodes not appear in menu's tree
Steps To Reproduce. logged with es_ES language
. General Setup || Application || Menu || Menu
. create new record asociated to module (this module has got module's language es_ES)
. automatically is created a translated record with language 'en_US'
. open menu's tree
. the new record doesn't appear
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0024192)
alostale (developer)
2010-02-12 10:04

With current pi (d0d75710c1ab) I'm not able to reproduce this issue.

It is working as expected:

When the menu entry is created within a module with es_ES as language, the header is in Spanish and translation are created for all other languages in the system (en_US). The menu entry appears in es_ES when logging in Spanish and in en_US (translation) when logging in English. If you remove the translation entry for that module, then it appears always in Spanish regardless the language you are using.
(0024267)
alostale (developer)
2010-02-15 12:42

It does not appear in the pop-up window in the menu tab.
(0024268)
hgbot (developer)
2010-02-15 13:36

Repository: erp/devel/pi
Changeset: 24dce3d8581aa37c0b5a026ddefd6b524a7037fc
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 15 13:36:59 2010 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/24dce3d8581aa37c0b5a026ddefd6b524a7037fc [^]

fixed bug 11069: In menu's tree not appear nodes without translate

---
M src/org/openbravo/erpCommon/utility/WindowTreeUtility.java
M src/org/openbravo/erpCommon/utility/WindowTree_data.xsql
---
(0024471)
marvintm (developer)
2010-02-17 11:38

Added a menu entry for a module with Spanish language set as the module language, removed the ad_menu_trl entry for the English language, and logged as English. Verified that the menu entry still can be seen in the "tree" popup view in the menu window.
(0024514)
hudsonbot (developer)
2010-02-18 00:30

A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/24dce3d8581a [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/7c1b489fb0a0 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/core/obx/OpenbravoERP-2.50CI.16459.obx [^]

- Issue History
Date Modified Username Field Change
2009-10-21 16:42 malsasua New Issue
2009-10-21 16:42 malsasua Assigned To => rafaroda
2009-10-23 06:55 rafaroda Assigned To rafaroda => alostale
2009-10-23 06:55 rafaroda Priority normal => high
2009-10-23 06:55 rafaroda Status new => scheduled
2010-01-20 10:24 networkb Target Version => 2.50MP12
2010-02-12 10:04 alostale Note Added: 0024192
2010-02-12 10:04 alostale Status scheduled => closed
2010-02-12 10:04 alostale Resolution open => unable to reproduce
2010-02-12 10:04 alostale Fixed in Version => 2.50MP12
2010-02-13 00:00 anonymous sf_bug_id 0 =>
2010-02-15 12:42 alostale Note Added: 0024267
2010-02-15 12:42 alostale Status closed => new
2010-02-15 12:42 alostale Resolution unable to reproduce => open
2010-02-15 12:42 alostale Fixed in Version 2.50MP12 =>
2010-02-15 12:43 alostale Status new => scheduled
2010-02-15 12:43 alostale fix_in_branch => pi
2010-02-15 13:36 hgbot Checkin
2010-02-15 13:36 hgbot Note Added: 0024268
2010-02-15 13:36 hgbot Status scheduled => resolved
2010-02-15 13:36 hgbot Resolution open => fixed
2010-02-15 13:36 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/24dce3d8581aa37c0b5a026ddefd6b524a7037fc [^]
2010-02-17 11:38 marvintm Note Added: 0024471
2010-02-17 11:38 marvintm Status resolved => closed
2010-02-17 11:38 marvintm Fixed in Version => 2.50MP12
2010-02-18 00:30 hudsonbot Checkin
2010-02-18 00:30 hudsonbot Note Added: 0024514
2010-03-10 18:28 anonymous sf_bug_id => 2967935


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker