Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0011039
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. PlatformminorN/A2009-10-19 15:172010-03-10 18:28
ReporterroklenardicView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version2.50MP12
StatusclosedFix in branchFixed in SCM revision46957ab44fec
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0011039: Active Session Detection

DescriptionThe session timeout (even though configurable) might cause frustrations to OPS customers:

   1. if set low they will be required to relog a few times a day
   2. if set high, closing the browser locks the session for too long

Proposed SolutionUse the pulling for alerts as a kind of heartbeat:
 * if this request for alerts is present (meaning the browser with the application is actually opened), then use the configured timeout value to expire the session
 * if the request for alerts is NOT present (probably a crashed or a closed browser) then automatically expire the session after a minute or so
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 00119672.50MP14 closedalostale Session is kept as active even after time out. 
related to defect 00268463.0PR14Q3 closedalostale Code running on tomcat start to search in remote tomcats is not needed anymore and can't work with Load Balanced Tomcats 

-  Notes
(0024578)
hgbot (developer)
2010-02-18 11:11

Repository: erp/devel/pi
Changeset: 0e103bbcd82f95075694406df501a9192529b74f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Feb 18 11:12:09 2010 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0e103bbcd82f95075694406df501a9192529b74f [^]

fixed issue 11039: Active Session Detection

---
M src-db/database/model/tables/AD_SESSION.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
M src/org/openbravo/erpCommon/obps/ActivationKey.java
M src/org/openbravo/erpCommon/utility/VerticalMenu.java
---
(0024588)
alostale (developer)
2010-02-18 12:47

Wrong commit comment, it is related with this issue, instead of 0011113

Repository: erp/devel/pi
Changeset: eecd5dedc0dcaba824f005798ab3c9605bf46648
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Feb 18 12:36:08 2010 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/eecd5dedc0dcaba824f005798ab3c9605bf46648 [^] [^]

fixed bug 11113: Small fixes and improved comments

---
M src/org/openbravo/erpCommon/obps/ActivationKey.java
M src/org/openbravo/erpCommon/utility/VerticalMenu.java
(0024596)
hgbot (developer)
2010-02-18 13:43

Repository: erp/devel/pi
Changeset: 160a70ea1019baea7976cbffc6658eacbd351ae2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Feb 18 13:44:45 2010 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/160a70ea1019baea7976cbffc6658eacbd351ae2 [^]

related to issue 11039: Fixed access problem for not admin roles

---
M src/org/openbravo/erpCommon/utility/VerticalMenu.java
---
(0024660)
hudsonbot (developer)
2010-02-19 16:35

A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/0e103bbcd82f [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/d22bdcc83354 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/core/obx/OpenbravoERP-2.50CI.16481.obx [^]
(0024662)
hudsonbot (developer)
2010-02-19 16:35

A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/160a70ea1019 [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/d22bdcc83354 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/core/obx/OpenbravoERP-2.50CI.16481.obx [^]
(0024683)
hgbot (developer)
2010-02-22 10:21

Repository: erp/devel/pi
Changeset: 46957ab44fec7999de0aa0009139a89462849bc3
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 22 10:22:54 2010 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/46957ab44fec7999de0aa0009139a89462849bc3 [^]

related to issue 11039
  Criteria to close sessions because of timeout now closes also sessions without last ping

---
M src/org/openbravo/erpCommon/obps/ActivationKey.java
---
(0024685)
iperdomo (developer)
2010-02-22 11:39

Sample of the log when closing 'not active' sessions:

10:04:18 [main] INFO org.openbravo.dal.core.DalLayerInitializer - Initializing in-memory model...
10:04:18 [main] INFO org.openbravo.base.model.ModelProvider - Building runtime model
10:04:24 [main] INFO org.openbravo.dal.core.DalLayerInitializer - Model read in-memory, generating mapping...
10:04:35 [main] INFO org.openbravo.dal.core.DalLayerInitializer - Dal layer initialized
10:04:35 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Quartz Initializer Servlet loaded, initializing Scheduler...
10:04:35 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Scheduler will start in 30 seconds.
10:04:35 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Storing the Quartz Scheduler Factory in the servlet context at key: org.quartz.impl.StdSchedulerFactory.KEY
10:04:35 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Storing ConfigParameters and ConnectionProvider in Scheduler Context.
10:04:35 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Initalizing singleton instance of org.openbravo.scheduling.OBScheduler
a3196480 10:06:14 [ajp-8009-1] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 0
a3196480 10:06:14 [ajp-8009-1] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 0
a3196480 10:28:10 [ajp-8009-5] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 1
a3196480 10:28:10 [ajp-8009-5] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 1
a3196480 10:29:08 [ajp-8009-5] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 2
a3196480 10:29:17 [ajp-8009-3] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 2
a3196480 10:29:20 [ajp-8009-6] INFO org.openbravo.erpCommon.security.SessionListener - Closed session079B127D22CB4E25AC93E8F547DE5C20
a3196480 10:30:03 [main] INFO org.openbravo.erpCommon.security.SessionListener - Closed session4DFB712A219C4ACA9CBE0E77C4922992
a3196480 10:30:03 [main] INFO org.openbravo.erpCommon.security.SessionListener - Closed session6B64BE41BE7D44E7A51DB3F7A5B25C79
a3196480 10:30:03 [main] INFO org.openbravo.erpCommon.security.SessionListener - Destroy context
a3196480 10:30:03 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Quartz Scheduler successful shutdown.
10:30:37 [main] INFO org.openbravo.dal.core.DalLayerInitializer - Initializing in-memory model...
10:30:37 [main] INFO org.openbravo.base.model.ModelProvider - Building runtime model
10:30:44 [main] INFO org.openbravo.dal.core.DalLayerInitializer - Model read in-memory, generating mapping...
10:30:54 [main] INFO org.openbravo.dal.core.DalLayerInitializer - Dal layer initialized
10:30:54 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Quartz Initializer Servlet loaded, initializing Scheduler...
10:30:54 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Scheduler will start in 30 seconds.
10:30:54 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Storing the Quartz Scheduler Factory in the servlet context at key: org.quartz.impl.StdSchedulerFactory.KEY
10:30:54 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Storing ConfigParameters and ConnectionProvider in Scheduler Context.
10:30:54 [main] INFO org.openbravo.base.OBSchedulerInitializerListener - Initalizing singleton instance of org.openbravo.scheduling.OBScheduler
a3196480 10:33:15 [ajp-8009-3] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 0
a3196480 10:33:15 [ajp-8009-3] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 0
a3196480 10:33:37 [ajp-8009-4] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 1
a3196480 10:33:37 [ajp-8009-4] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 1
a3196480 10:34:12 [ajp-8009-1] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 1
a3196480 10:34:37 [ajp-8009-4] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 2
a3196480 10:34:44 [ajp-8009-4] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 2
a3196480 10:34:46 [ajp-8009-2] INFO org.openbravo.erpCommon.security.SessionListener - Closed sessionC57FF9679088488F98B1BB0EBF0F0657
a3196480 10:38:22 [ajp-8009-2] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 2
a3196480 10:38:22 [ajp-8009-2] INFO org.openbravo.erpCommon.obps.ActivationKey - Deactivated session: C43171EECDCA4D2C9B7863F5ADB5BF8A beacuse of ping time out. Last ping: 2010-02-22 10:34:28.44. Last valid ping time: Mon Feb 22 10:36:22 UTC 2010
a3196480 10:38:22 [ajp-8009-2] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions after timeout cleanup: 1
a3196480 10:38:22 [ajp-8009-2] INFO org.openbravo.erpCommon.obps.ActivationKey - Active sessions: 1
(0024687)
iperdomo (developer)
2010-02-22 12:11

Tested on the following environment:
- OBPS EC2 machine 2.50MP11 updated with a core OBX (OpenbravoERP-2.50CI.16481.obx)
- Used the option 'restart server' after the core upgrade

My only 'concern' is the latency of 2 minutes after a session could be considered 'dead'. From the user perspective could be too much?
(0025004)
hudsonbot (developer)
2010-03-03 13:48

A changeset related to this issue has been promoted to main after passing a series of tests and an OBX has been generated:

Changeset: http://code.openbravo.com/erp/devel/main/rev/46957ab44fec [^]
Merge Changeset: http://code.openbravo.com/erp/devel/main/rev/17ddf2c3af51 [^]
Tests: http://builds.openbravo.com/view/devel-int/ [^]
OBX: http://builds.openbravo.com/erp/core/obx/OpenbravoERP-2.50CI.16508.obx [^]

- Issue History
Date Modified Username Field Change
2009-10-19 15:17 roklenardic New Issue
2009-10-19 15:17 roklenardic Assigned To => iciordia
2010-01-15 15:32 iciordia Assigned To iciordia => alostale
2010-01-15 15:32 iciordia Priority normal => urgent
2010-01-15 15:32 iciordia Status new => scheduled
2010-01-15 15:32 iciordia Fixed in Version => 2.50MP13
2010-01-28 12:26 iciordia Relationship added related to 0011967
2010-02-12 12:22 alostale Relationship replaced has duplicate 0011967
2010-02-18 11:11 hgbot Checkin
2010-02-18 11:11 hgbot Note Added: 0024578
2010-02-18 11:11 hgbot Status scheduled => resolved
2010-02-18 11:11 hgbot Resolution open => fixed
2010-02-18 11:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0e103bbcd82f95075694406df501a9192529b74f [^]
2010-02-18 12:47 alostale Note Added: 0024588
2010-02-18 13:43 hgbot Checkin
2010-02-18 13:43 hgbot Note Added: 0024596
2010-02-18 13:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/0e103bbcd82f95075694406df501a9192529b74f [^] => http://code.openbravo.com/erp/devel/pi/rev/160a70ea1019baea7976cbffc6658eacbd351ae2 [^]
2010-02-19 16:35 hudsonbot Checkin
2010-02-19 16:35 hudsonbot Note Added: 0024660
2010-02-19 16:35 hudsonbot Checkin
2010-02-19 16:35 hudsonbot Note Added: 0024662
2010-02-22 10:21 hgbot Checkin
2010-02-22 10:21 hgbot Note Added: 0024683
2010-02-22 10:21 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/160a70ea1019baea7976cbffc6658eacbd351ae2 [^] => http://code.openbravo.com/erp/devel/pi/rev/46957ab44fec7999de0aa0009139a89462849bc3 [^]
2010-02-22 11:39 iperdomo Note Added: 0024685
2010-02-22 12:11 iperdomo Note Added: 0024687
2010-02-22 12:11 iperdomo Status resolved => closed
2010-02-22 12:11 iperdomo Fixed in Version 2.50MP13 => 2.50MP12
2010-02-23 00:00 anonymous sf_bug_id 0 =>
2010-03-03 13:48 hudsonbot Checkin
2010-03-03 13:48 hudsonbot Note Added: 0025004
2010-03-10 18:28 anonymous sf_bug_id => 2967933
2014-06-11 18:26 shuehner Relationship added related to 0026846


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker