Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0010898
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Otherscriticalhave not tried2009-10-07 13:592009-10-23 00:01
ReportershuehnerView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision6fa216c45a88
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0010898: Api check build 165 fails

DescriptionThis api check build fails:

http://builds.openbravo.com/job/erp_devel_pi-module-integrity-test/165/console [^]

org.openbravo.erpCommon.obps:
Missing
method org.openbravo.erpCommon.obps.ActivationKey.getSubscribedModules(boolean): missing in /var/www/localhost/htdocs/japi/165
method org.openbravo.erpCommon.obps.ActivationKey.isModuleSubscribed(java.lang.String, boolean): missing in /var/www/localhost/htdocs/japi/165
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0010822 closedalostale Message displayed when module license is over or not yet started is not correct 

-  Notes
(0020847)
shuehner (administrator)
2009-10-07 14:01

Change introduce by thsi changeset:

changeset: 5170:d54363bb8b4a
user: Asier Lostalé <asier.lostale@openbravo.com>
date: Wed Oct 07 09:35:37 2009 +0200
files: src-db/database/sourcedata/AD_TEXTINTERFACES.xml src/org/openbravo/erpCommon/ad_forms/ModuleManagement.java src/org/openbravo/erpCommon/ad_forms/ModuleManagement_ErrorCommercial.html src/org/openbravo/erpCommon/ad_forms/ModuleManagement_ErrorCommercial.xml src/org/openbravo/erpCommon/obps/ActivationKey.java
description:
fixed bug 0010822: Message displayed when module license is over or not yet started is not correct
(0020851)
alostale (developer)
2009-10-07 15:22

This API breakage solves issue 0010822.

When checking the commercial modules an instance is subscribed to, it just checked whether the module was currently accessible thus the isModuleSubscribed method returned a boolean but it did not distinguish if the module was not available because it was not subscribed or because the license was expired or not active yet. Now this method returns the actual status for the module, therefore it cannot be a boolean value.

Apart of this, this method is very unlikely to be used by any module since it just check if a module is registered for an instance, so I don't think this change add any risk.
(0020946)
pjuvara (reporter)
2009-10-13 07:16

Exception approved. Please document with an alert.
(0020960)
hgbot (developer)
2009-10-13 09:48

Repository: erp/devel/api-checks
Changeset: 6fa216c45a88df4db87e789bc3e7283048de126f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Oct 13 09:47:54 2009 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/6fa216c45a88df4db87e789bc3e7283048de126f [^]

fixed issue 0010898: Api check build 165 fails

---
M java/reference/250.japi.gz
---

- Issue History
Date Modified Username Field Change
2009-10-07 13:59 shuehner New Issue
2009-10-07 13:59 shuehner Assigned To => alostale
2009-10-07 14:01 shuehner Note Added: 0020847
2009-10-07 14:01 shuehner Relationship added related to 0010822
2009-10-07 15:22 alostale Note Added: 0020851
2009-10-07 15:22 alostale Assigned To alostale => pjuvara
2009-10-09 09:24 psarobe Status new => scheduled
2009-10-09 09:24 psarobe fix_in_branch => pi
2009-10-13 07:16 pjuvara Note Added: 0020946
2009-10-13 07:16 pjuvara Assigned To pjuvara => alostale
2009-10-13 09:48 hgbot Checkin
2009-10-13 09:48 hgbot Note Added: 0020960
2009-10-13 09:48 hgbot Status scheduled => resolved
2009-10-13 09:48 hgbot Resolution open => fixed
2009-10-13 09:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/6fa216c45a88df4db87e789bc3e7283048de126f [^]
2009-10-22 09:06 psarobe Status resolved => closed
2009-10-23 00:01 anonymous sf_bug_id 0 => 2884256


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker