Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0010603
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Otherscriticalhave not tried2009-09-15 10:142009-09-18 00:00
ReportershuehnerView Statuspublic 
Assigned Toiperdomo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision75b189a7b83b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0010603: API check build 139 fails with warnings

DescriptionThe following build fails with warning:

http://builds.openbravo.com/job/erp_devel_pi-module-integrity-test/139/console [^]

This issue is about this WARNING:

  Column size changed from 20 to 100: column: AD_HEARTBEAT_LOG.OS_VERSION
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00105782.50MP6 closediperdomo Heartbeat process cannot be enabled in Openbravo's virtual appliance 

-  Notes
(0020035)
iperdomo (developer)
2009-09-15 10:36
edited on: 2009-09-15 10:36

Type: Change column datatype

Description: AD_Heartbeat_Log.OS_Version length change from VARCHAR(20) to VARCHAR(100)

Comments: The heartbeat process can't be enabled in the virtual appliance due to a too long os reported version. Usually a linux box reports something like 2.6.30-gentoo-r5, but the rPath linux based is reporting 2.6.29.6-0.6.smp.gcc4.1.x86.i686 a value too long to store it in a 20 character column. This could also happen in other systems reporting a os version longer than 20 characters.

Solution: Increase the length of the OS_Version column to handle long values.

Risk: Low (It's a log table)

(0020036)
pjuvara (reporter)
2009-09-15 10:42

I approve this change.

The risk is low or none. It might not be worth it but let's go ahead anyway with the publication of the exception to the mailing list and updating the exception list.
(0020037)
hgbot (developer)
2009-09-15 10:49

Repository: erp/devel/api-checks
Changeset: 75b189a7b83bd665b21589a80eef873b0a2034dc
Author: Iván Perdomo <ivan.perdomo <at> openbravo.com>
Date: Tue Sep 15 10:49:19 2009 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/75b189a7b83bd665b21589a80eef873b0a2034dc [^]

Fixes issue 10603: Increased length of os_version column

---
M model/model/tables/AD_HEARTBEAT_LOG.xml
M model/sourcedata/AD_COLUMN.xml
---

- Issue History
Date Modified Username Field Change
2009-09-15 10:14 shuehner New Issue
2009-09-15 10:14 shuehner Assigned To => iperdomo
2009-09-15 10:23 iperdomo Status new => scheduled
2009-09-15 10:23 iperdomo fix_in_branch => pi
2009-09-15 10:24 iperdomo Relationship added related to 0010578
2009-09-15 10:36 iperdomo Note Added: 0020035
2009-09-15 10:36 iperdomo Note Edited: 0020035
2009-09-15 10:37 iperdomo Assigned To iperdomo => pjuvara
2009-09-15 10:42 pjuvara Note Added: 0020036
2009-09-15 10:42 pjuvara Assigned To pjuvara => iperdomo
2009-09-15 10:49 hgbot Checkin
2009-09-15 10:49 hgbot Note Added: 0020037
2009-09-15 10:49 hgbot Status scheduled => resolved
2009-09-15 10:49 hgbot Resolution open => fixed
2009-09-15 10:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/75b189a7b83bd665b21589a80eef873b0a2034dc [^]
2009-09-17 11:41 iperdomo Status resolved => closed
2009-09-18 00:00 anonymous sf_bug_id 0 => 2861012


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker