Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0023056
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2013-02-12 13:122013-03-02 05:48
ReportercaristuView Statuspublic 
Assigned Toshankarb 
PriorityurgentResolutionfixedFixed in Version3.0MP21
StatusclosedFix in branchpiFixed in SCM revision485822d38b74
ProjectionnoneETAnoneTarget Version3.0MP21
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0023056: Ordered Quantiy field of Sales Order is not properly auto filling the grouping separator

DescriptionIn ordered quantity field of [Sales Order] window, the application is auto-filling the grouping separator, but not in the right place if we type a quantity greater than 9999.
Steps To Reproduce1) Go to [Sales Order] window and create a new header
2) Go to the lines tab and in the ordered quantity type the following quantity: 10000
3) The grouping separator is added in the wrong place: 1,0000
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0023136 closedshankarb Quantity field behaves differently in Sales Order Line and Purchase Order Line 
related to defect 00284273.0PR15Q2 closedAugustoMauch Price is not rounded to calculate the line net amount in Create Lines process of Purchase Order 
related to defect 0031901 closedcaristu decimal value can't be changed by trigger/observer after manual edition in form view 
related to defect 00322023.0PR16Q2 closedcaristu Error in add payment when editing the amount of a record in order/invoice grid 

-  Notes
(0056538)
hgbot (developer)
2013-02-19 08:08

Repository: erp/devel/pi
Changeset: 1eec3c95b1fd9bd3afd5d617439b9457a51ce535
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Tue Feb 19 12:36:24 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/1eec3c95b1fd9bd3afd5d617439b9457a51ce535 [^]

Fixes Issue 0023056: Ordered Quantiy field of Sales Order is not formatted properly.

Grouping seperators were not applied correctly to the field.
Used existing focusNumberInput() method to format the same.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0056624)
hudsonbot (developer)
2013-02-20 04:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d828167a9e83 [^]

Maturity status: Test
(0056675)
AugustoMauch (developer)
2013-02-21 10:56

Code reviewed and verified in pi@9700d819690d
(0056752)
hgbot (developer)
2013-02-26 04:31

Repository: erp/devel/pi
Changeset: 2fe7a6f9618ce3dc201298f60a314ee1acb030bd
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Tue Feb 26 09:00:10 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/2fe7a6f9618ce3dc201298f60a314ee1acb030bd [^]

Fixes Issue 0023158, Related to Issue 23056 : Backout changeset 1eec3c95b1fd

Backout fix for the Issue 23056 because it causes regression 23158.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0056754)
shankarb (developer)
2013-02-26 04:32

Reopened because the fix causes regression issue https://issues.openbravo.com/view.php?id=23158. [^]
(0056797)
hgbot (developer)
2013-02-27 07:42

Repository: erp/devel/pi
Changeset: 485822d38b744c64e63148db75ded3f0f1b52346
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Wed Feb 27 12:10:05 2013 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/485822d38b744c64e63148db75ded3f0f1b52346 [^]

Fixes Issue 0023056,23136 : Formatting issues in ordered quantity in sales order

Set the item value to non formatted value, after saving the Textual Value for database saving purposes.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-number.js
---
(0056799)
AugustoMauch (developer)
2013-02-27 11:02

Code reviewed and verified in pi@2502e500a99d
(0056912)
hudsonbot (developer)
2013-03-02 05:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f5db629e7058 [^]

Maturity status: Test

- Issue History
Date Modified Username Field Change
2013-02-12 13:12 caristu New Issue
2013-02-12 13:12 caristu Assigned To => dbaz
2013-02-12 13:12 caristu Modules => Core
2013-02-12 13:12 caristu Triggers an Emergency Pack => No
2013-02-12 13:13 caristu Issue Monitored: networkb
2013-02-12 13:33 caristu Description Updated View Revisions
2013-02-13 13:38 dbaz Assigned To dbaz => AugustoMauch
2013-02-14 12:33 AugustoMauch Assigned To AugustoMauch => shankarb
2013-02-19 08:06 shankarb Review Assigned To => AugustoMauch
2013-02-19 08:07 shankarb Status new => scheduled
2013-02-19 08:07 shankarb fix_in_branch => pi
2013-02-19 08:07 shankarb Issue Monitored: AugustoMauch
2013-02-19 08:08 hgbot Checkin
2013-02-19 08:08 hgbot Note Added: 0056538
2013-02-19 08:08 hgbot Status scheduled => resolved
2013-02-19 08:08 hgbot Resolution open => fixed
2013-02-19 08:08 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1eec3c95b1fd9bd3afd5d617439b9457a51ce535 [^]
2013-02-20 04:51 hudsonbot Checkin
2013-02-20 04:51 hudsonbot Note Added: 0056624
2013-02-21 10:56 AugustoMauch Note Added: 0056675
2013-02-21 10:56 AugustoMauch Status resolved => closed
2013-02-21 10:56 AugustoMauch Fixed in Version => 3.0MP21
2013-02-21 11:01 AugustoMauch Relationship added related to 0023136
2013-02-26 04:31 hgbot Checkin
2013-02-26 04:31 hgbot Note Added: 0056752
2013-02-26 04:32 shankarb Note Added: 0056754
2013-02-26 04:32 shankarb Status closed => new
2013-02-26 04:32 shankarb Resolution fixed => open
2013-02-26 04:32 shankarb Fixed in Version 3.0MP21 =>
2013-02-27 07:42 hgbot Checkin
2013-02-27 07:42 hgbot Note Added: 0056797
2013-02-27 07:43 hgbot Status new => resolved
2013-02-27 07:43 hgbot Resolution open => fixed
2013-02-27 07:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/1eec3c95b1fd9bd3afd5d617439b9457a51ce535 [^] => http://code.openbravo.com/erp/devel/pi/rev/485822d38b744c64e63148db75ded3f0f1b52346 [^]
2013-02-27 11:02 AugustoMauch Note Added: 0056799
2013-02-27 11:02 AugustoMauch Status resolved => closed
2013-02-27 11:02 AugustoMauch Fixed in Version => 3.0MP21
2013-03-02 05:48 hudsonbot Checkin
2013-03-02 05:48 hudsonbot Note Added: 0056912
2015-01-23 14:49 AugustoMauch Relationship added related to 0028427
2016-01-25 12:50 caristu Relationship added related to 0031901
2016-02-11 15:46 caristu Relationship added related to 0032202


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker